Trying to connect my Mac as a network drive or as a Plex DLNA server

I’m having issues trying to get the music library on my mac to connect as a network drive. I’ve tried a couple different methods, so help with either of them would be appreciated (basically if i could get one of these to work, that would be great)

Shared folder/server - 2013 MacPro connected to network (Orbi) via ethernet cable.
Raspberry Pi 4B w/ HiFiBerry DAC+ Pro, Volumio running version 2.778

Method 1:
On my Mac:
In my system preferences, I go to “Sharing” section and turned on file sharing for the folder with my library. In the Options it is set to share as SMB and AFP. My account/username is set to read/write and “Everyone” is set to “Read Only.” It says file sharing is on and I have a standard IP address (XXX.XXX.X.XX).

On Volumio:
I go to Settings/Sources. Set the NAS IP address as the the IP address in the sharing menu of my Mac in the same format (I tried both on its own and with smb:// before it). For the path I copy and pasted the path from the folder on my Mac (/Users/username/Music/Music/Media.localized). Enter my user name and password.

I get the following error:
Error in mounting share MacPro
(22): Invalid argument. Refer to the mount cifs(8) manual page (e.g. man mount.cifs)

Alternately, I’m already running a Plex server on this machine, which brings me to…
Method 2:
In Plex:
In Plex settings I turned on “Enable the DLNA server” and saved changes. I didn’t modify any of the other settings.

On my modem/router:
UPnP is turned on.

On Volumio:
UPnP Renderer and DNLA Browser are both on and active. I don’t see anything showing up. Where should this library be showing up if it does work?

I realize these are both pretty different methods, but any help with either of these would be appreciated. I would be happy with just getting one of these to work!

In Nas IP put 192.168.1.Xxx or what ever FIXED IP address of Mac. If not fixed you may lose mount on restart. Make fixed in Network- advanced- tcp/ip-manual.

Then in path JUST put name of your shared folder eg: Mac-music. No other path details.

You may need to add your Mac username and password.


So I manually set my WiFi connection to be a fixed IP in Network/Advanced. Put my user name and password, just the folder name for the final destination (Media), and now I am getting the following error

Error in mounting share MacPro
exec error Error: Command failed: /usr/bin/sudo /bin/mount -t cifs -o username=‘xxxx’,password=‘xxxx’,ro,dir_mode=0777,file_mode=0666,iocharset=utf8,noauto,soft ‘//’ ‘/mnt/NAS/MacPro’ Unable to find suitable address.

I’d also like to add the fact that I am sharing multiple drives/folders on this machine as I use it as home server. No sure if that makes a difference or not.

Well having same problem mounting the Mac share. Tried absolutely everything w/o success. There are other threads suggesting using “ver=3.0” or 1.0, 2.0, 3.1 in the parameter window. Did not work for me. I see this seems to be a substantial problem, as people having same issue with mounting NAS nfs shares, especially after the last update.
I even installed a nfs server on mac trying to force nfs (Mac does only smb and afs) but his did not work either. I am curious about someone from Volumio really looks into the problem.
With regards to DLNA server, I have managed to install the MinimServer on Mac and this works fine with Volumio. I see all the content under “Media Servers”, though it does not populate the Volumio library. I have been using Arkuda ArkMS before, but this did not work properly and I could see only album titles and not the tracks. Minimserver is audio file optimised, so this is perhaps a good choice.

I have no idea what I did, but it just started working out of nowhere and Volumio is currently scanning my music library. For the most part I followed what domchocolate said.

I rejiggered my network and Mac a bit over the weekend so that may have something to do with it. For reference, when I set up my static IP, under “Configure IPv4” I used “Using DHCP with manual address” and then set my manual address. My MacPro is also connected via Ethernet but my Pi is connected via wifi. Not sure if any of this makes any difference but it is working for me now.

¯ \ _ (ツ) _ / ¯