Trouble after update to 2.712


after updating volumio to version 2.712 (for x486) i can not reach my musiclibrary, neither albums or artists. Only the last 100 songs can be played.

What is the problem. Nothing works anymore. Please help!!

I have similar problems with both Pi3b+ and the tinkerboard. In setings, library stored in NAS shows network drive mounted but no album and track count indicated Update or rescan not responsive. If lucky the library appears at home menu but only partial contents and those can play! Then the library disappears again. Now have to resort to going to home menu media servers and find the nas then they are all there and play fine. The Pi3B+ also could not recognize an USB hdd drive which it was able to recognize before the update.

PC version in same update runs in NUC both internal ssd and nas no problem at all!

Hope there’s a rollback version… regret that a back up image wasn’t performed before this update

Please send logs so we can troubleshoot what’s the problem on your end. … oting.html

Thanks. Logs sent


this is my logfile:
The Problem is still the same, even after a factory reset and newly updating volumio.

Hope for some help.

Same issue
The problem seems to come from mpd.conf

max_output_buffer_size "8192000"


max_output_buffer_size "819200"
it works (for me)

This is the log for the Pi3 B+
The previous log was for the Tinkerboard
The X86 update for NUC was fine in terms of the problems experienced in the pi3 and tinkerboard.
Thanks for the help.

Thanks for the input but computer idiot here so how to amend that?

wait for a fix :wink: if it is really the cause, it won’t late

Notice there’s a new update! Will try now. Thank you for the quick action.

Just tried 2.713 on Pi3 B+ better but scanning of NAS library not possible to go over 23x albums where I have over 2000 albums and the strange thing is after 23x albums then it will stop and show exactly 127 albums every time. Library shows the same 127 albums. Here’s the log:

Will try my luck with the Tinkerboard now. Thanks!

Save playback options and retry

Thanks! Tinkerboard scanning of NAS albums looks good now. Same count as the no problem pc x86/x64 2.712.

However, the pi3 b+, followed your instruction to save playback option and retry… no success. Did a factory reset, saved the playback options first then did the scanning… stopped at 31x albums then this time showed zero albums… here’s the log:

2.713 seems to have issues with media scanning, too. My USB drive is not detected, and when detected it just scans a few folders and that’s it. It was working fine with the last January build.