touch_display plugin help please

I am trying to set up the touch_display plugin and I am running into an issue.

I purchased one of the reccommended displays from here…
here is the screen I purchased

I tried the install and it wouldn’t complete the install and the display would not activate…

I downloaded the latest version of Volumio ( burned it to the SD (after formatting it)…
connected the HDMI and USB…
Powered on the R-Pi3…
Launched Volumio…
Didnt do any config…
Attempted to install the touch _display plug-in via the plug-in menu in Volumio…
The install hangs at 70%… on the top of the window it says install completed successfully, the last message says it is “Disabling Kiosk Service” and sits at 70% for over 30 minutes so far… This is the same behavior I saw before updating the image.

I saw on the tutorial that sometimes the Waveshare displays need a special driver… anyone have an idea what I need to do to get the display to work? I get 100% no display, Im not sure if it is even powering up.

If the page refreshes (onmy tablet) or if I hit f5 on my laptop, the 70% screen goes away and under the Plug-ins screens it shows as successfully installed. I have enabled the plug-in and rebooted with 100% no change to the display, no flash, no splash screen, no anything…

well i followed the directions here and installed the keyboard config and now the plug-in install completes,but i still have no display on the HDMI connected display.

any other ideas? Im still searching for solutions too…

I have tried 3 HDMI and USB cables with the same result… I have also tried plugging the USB directly into a higher output USB brick to see if it wasnt getting enough power form the R-PI usb port…

well i tried again from scratch and now trying to set the keyboard config it says it cant find the file.

looking on waveshare site they list to add
hdmi_cvt 1024 600 60 6 0 0 0
to the /boot/config.txt: i did this and now the install hangs at 70%
Adding plugin to registry
Plugin Successfully Installed
Disabling Kiosk Service

rebooted and still no display on the screen…


i installed the plugin this night.
first the installation stucked by 70%, choose a keyboard. i uninstalled the plugin, shutdown, unplugged my keyboard, installed the plugin again with success. enabled the plugin, blackscreen hdmi, disabled the plugin and enabled again ==>> success output hdmi.


maybe the problem is the screensaver.

I reburned teh SD card with the latest 389 image
canceled out of the config
installed the plugin and it completed
I then connected via SSH and ran nano /boot/config.txt
I added the following to the config.txt file as per the directions on the waveshare site
hdmi_cvt 1024 600 60 6 0 0 0
rebooted and the screen is still black

I added a powed y cable plugged into a seperate power supply
still black screen

Yes the plug-in is enabled :slight_smile:

What screen are you using?

you said you choose a keyboard? I have never been asked to choose a keyboard, and I dont see any place to choose a keyboard…

you said maybe its the screen saver… I dont see any place to set a screen saver, I would think if it was a screen saver it would at least start up but then go black?

HMM I think the display is bad…
I hooked the HMDI up to a monitor and I get display, the touches register on the touchscreen and show on the monitor.

It feels like the screen isnt getting enough power maybe?

Either the screen is bad or I am not powering it correctly (there are no directions on the waveshare site to explain what power requirements are) I have tried a y connector (like you would use to power an external CD drive, two usb plugs to one cord to supply twice the power) with no love…

I use no touch screen, i use a monitor on my second system with the kodi plugin or since this evening for displaying the played songs. I prefer a tablet to the operation.

yes, I was asked which keyboard I want to select. the installation routine recognized my keyboard which I use for kodi. A selection was not possible, error in the installation routine.

screensaver or better a kind of standby. after a while my monitor goes also black and without the keyboard the monitor stays black. perhaps your screen waiting for “hallo good morning”! my monitor stayed black with the first enable, the second enable gave him the signal for output.

Amazon got a replacement screen to me today, all is working, it was a bad screen. :smiley: