thanks for your great work! I just tried to install the touch display plugin to use the official raspberry touch display on a rpi3 / hifiberry dac+ with a freshly installed volumio-2.001-2016-10-15. The files are downloaded but when installing the dependencies, I simply get “Error” :

Downloading plugin at END DOWNLOAD: Creating folder on disk Unpacking plugin Checking for duplicate plugin Copying Plugin into location Installing dependencies The folowing error occurred when installing the plugin: Error

Does anyone know more about that “Error”? Does it help to install any dependency manually? If so, what are the dependencies?

same problem here with spotify plugin. Tried to install dependencies, you can find them in the in the zip file mentioned in the installation details. The tar.gz file mentioned in the install is still available, so this couldnt be the problem…

It would be nice if there was a manual install option, but i can’t find a simple explanation at … rview.html. Installing tar file isn’t sufficient, the files in the zip file should get a place too. Where in /data/plugins/ isn’t exactly clear.

Searched volumio2 on github to find where this message is comming from: … manager.js

It seems the plugin installation requires the original password! See line 819

exec('echo volumio | sudo -S sh ' + installScript+' > /tmp/installog', 

To (temporary) reset password use sudo, otherwise the message "new password is too simple wil occur:

sudo passwd volumio

It would be nice to have an appropriate message about this. A field to enter the password during installation when this error occurs, would even be better!

marcos, you made my day! thank you so much for your hint. just did a fresh install of 2.011 and installed the plugin before changing the password - it worked like a charm and the display now shows the web-ui yeaha

I just came across this problem installing any plugin after changing my password.

First try changing it back to ‘volumio’:

~$ passwd Changing password for volumio. (current) UNIX password: Enter new UNIX password: Retype new UNIX password: Bad: new password is too simple

So I changed line 25 in /etc/pam.d/common-password from:

password        [success=1 default=ignore] obscure sha512


password        [success=1 default=ignore] sha512

In other words, I just removed the word obscure. Then I reset the password and installed the plugins. Then I changed the password back to a more secure one, and reinstated the obscure parameter in /etc/pam.d/common-password.

by the way, is it possible to change the resolution of the screen ?

I had same problem last week. You could also try sudo passwd .