Totally stuck in various bugs


I’m the owner of a volumio primo with lifetime license
I didn’t use my device for 3 monthes due to temporary change of music hardware configuration (integrated amplifier with airplay capabilities) and because, even If i found that using LMS could fix the small bugs i faced using spotify plugin, i was not totally satisfied by my user experience.
A couple of days ago, I tried to come back to volumio, i did the pending update and tried to figure all this out.
The new situation was : even more bugs with last spotify version (due to librespot, strange because forked DAAP didn’t face this issue) and now even LMS plugin is totally broken (native and docker version).

I’ve posted corresponding log in two topic elsewhere, i won’t post them again here. during the painfull process, I tried via /dev to install beta, this worked but din’t fix spotify and LMS issues.

Now I try to revert back to standard volumio version following this procedure from the documentation

Factory Reset Via USB Thumb Drive
• Get a USB Thumb Drive
• Format it as “FAT32”
• Download the factory reset file from
• Copy the file on the thumb drive and make sure it’s called exactly “factory_reset”
• Remove power from Primo
• Plug the thumb drive to one of the USB ports
• Apply power to Primo
• IMPORTANT: During this phase the unit might restart multiple times and this factory reset
will take about 10 minutes

But it doesn’t work I’M stuck to 3.369 version.
Of course standard factory reset via web interface doesn’t work more
To help here is my log trying to cancel test mode

info: CALLMETHOD: system_controller system setTestSystem false
info: CoreCommandRouter::executeOnPlugin: system , setTestSystem
error: Cannot delete test file: Error: Command failed: rm /data/test
rm: cannot remove '/data/test': No such file or directory

In last resort I’ve tried to open my case to connect micro usb port to my linux and windows PC, I can’t even see it in the explorer… I Was ready to manually flash emmc using tinkerboad volumio image but standard UMS procedure i found somewhere in this forum didn’t work for me and I couldn’t succeed…

Does all this things sound to you ? Could it be hardware related ? Could i expect any help ?

Sorry for this long message

Since you have the Primo you have the right to get dedicated support from Volumio, but you have to create a support ticket at Jira Service Management

I think you will get help quicker that way!

1 Like

Ok, just did it, even if I don’t see how it help the community and improve the average knowledge
Always better to share solution in a forum at my sense
Thank you for your quick answer anyway

Well, you can share it with us in the community later.

If you create a ticket you can follow the progress, and the support people at Volumio will see it much faster then waiting for them to see your post in the community forum.

1 Like


This is Davide, tech support
Just received your ticket!

I’ll get back to you soon



1 Like

I’ll do it for sure

Thank you Davide, nice to hear you again

As promised, Davide input

Dear Customer,

hello and thanks for reaching out,

This is Davide, volumio tech support

The software version you installed is a beta test release, not finally approved (it will be officially released within the first weeks of October)
It means that some bugs still need to be solved.
Beta test version concerns only official pro features (especially the new ones, such local playback, chromecast and sonos casting)

The issues you report involve Spotify and LMS, these plugins are not official pro features included in Volumio, they are 3rd parties, especially LMS.
No tests and QA is done on 3rd parties plugins. About issues related to them please contact directly their authors via or share the logs with community members, opening or commenting proper posts.
(Note: Did you install the latest Spotify plugin version available in the plugin store? Delete the previous one before.)

Here the procedure to save the log:
How to send a log link for a bug report?

Then, the factory reset (via web UI or usb thumb drive) doesn’t affect the software version, but only the system settings. It’s not possible to revert to a previous version (you can do it only reflashing the Primo eMMC), but

If you open the Primo, you lost the warranty (not suggested)

The Primo HIFI ED (lifetime) IMG is not the same as Tinkerboard S, and it’s not public

At this point, my suggestion is to test the new features included in the latest version and wait for the next official one.

Hoping to have been clear and helpful

Here for any further info


My answer

Hi Davide, thank you for your answer
Firstly, sad to hear that Spotify is not part of official volumio package. It’s clearly something volumio should not let in community hands since a lot of competitor have it full functionnal… Please people at volumio seriously consider make it functionnal it looks feasible

Secondly, As I’m not sure to be on normal or beta track, how can I be sure that I will receive future stable release

Thirdly, Last time we met together, you pass a wget command via ssh that fix update issue, there is nothing comparable to do here ? I’m surprised

have a nice weekend

Final words:

Ciao Vincent,

pleased to find you again so :wink:

About spotify, until now, it has been developed by our community guys (mods and devs, some of them). We preferred to focus our energies on other much more requested (and Hi-res) streaming services.
But one of our task in todo list is to implement Spotify native, we are collecting feedbacks to order some priorities.

The way to come back to OS NORMAL MODE is:

go to /dev page (volumioIP/dev in the web addresse bar)

click on FALSE button, under the TEST MODE section

There is no way as I said to come back “easily” to the official latest version

It needs to keep our hand in ssh (we cannot send ssh string code to the end users) and this is not possible, sorry

BTW if your problem was only related to Spotify and LMS plugins, nothing more involved, nothing changes at all from the previous and latest official 3.324 sw version.



1 Like


Ok ok, first of all thank to Davide who’s answer was nice, clear and very quick, this was really helpful to me.
The main misunderstandings was in the fact that I believed spotify and spotify connect were officially supported by volumio official, but it was not the case and to be honest volumio has never claim for it, so nothing more to say other than I should have been more careful before buying the unit with a spotify license in hands. :sweat_smile:

Now that said, The epilogue is not so sad since I succeed at configuration of a docker instance of LMS on my terramaster NAS and now stream flawlessly to my primo using UPNP/DLNA pluging by french genius Philippe44 :rooster: :fr: :joy:

Everything is here, spotify, radio paradise, mixcloud, DSD in native mode (!!) so I’m now in happy testing mode.

Regarding new beta volumio 3 that I’m forced to test for few days, it look very promising, the UI is even smarter than previous version, everything more accessible, good work team. Just a concern about plugin system not easy to maintain across version (2 major plugin broken not acceptable for me), maybe take a look at it and redesign it.

1 Like

Ok things are always complicated, using volumio as a upnp/dlna renderer, I get serious and odd error after a certain time and especially when changing track. Based on my crawl on slimdevice forum, it could be linked to upmpdcli that look deprecated even in beta volumio version…

volumio@volumio:~$ sudo apt-cache policy upmpdcli
  Installed: 1.5.8-1~ppa1~buster
  Candidate: 1.5.8-1~ppa1~buster
  Version table:
 *** 1.5.8-1~ppa1~buster 100
        100 /var/lib/dpkg/status
upmpdcli 1.5.20 has fixes for the uprcl local Media Server module.
libnpupnp release 5.0.0, and libupnpp 0.22.2 fix a problem on the Control Point side. The device side (upmpdcli) should not be affected.
upmpdcli 1.5.19 fixes small issues.
1.5.17 fixes a small issue preventing the Qobuz plugin from working.
Many things happened since last year... See the release notes.
libnpupnp 4.1.1 lets Samsung TVs work with Gerbera built with libnpupnp.
The upmpdcli Media Server now have a Deezer plugin (1.5.9). Only 128 kb/s streams unfortunately.
Version 1.5.5. Fix initial issues in 1.5.2. See the release notes. Note: Tidal access does not work any more at all. Qobuz access works through the media server, not through the Kazoo or Lumin login (OpenHome Credentials).
Version 1.5.2. Create separate UPnP/AV and OpenHome devices. See the release notes.

I’m going to claim for an update to volumio team :confused:

For the moment, I circumvent the back up solution (UPnP/dlna) limitation by using lms airplay plugin. I 'm feeling a little quality loss and hardware volume control is not working but everything else does

Hey, you are the only TerraMaster NAS user that I can see in this community. May I know what model do you use to store your music collections?

F221, this is good device but I would rather buy a hpe proliant