Totally standalone player in the making

Hi Everyone,
As I mentionned in my introduction, I’m looking for a solution to a problem I have with my (future standalone) player.
I made a box with everything included: Boss DAC, touchscreen, SSD and infra red receiver. The problem is I do not have internet connection at home(when I need it on my computer, I just share my android smartphone’s connection). But for first, I can’t use it for installing the touchscreen plugin. So I would like to know if it is possible to install plugins manually. After doing this I’ll (maybe) could use my Android connection to install all the plugins I need(infrared receiving and bluetooth).
The problem is I do not know anything about coding. I managed to reach in Volumio with the Terminal of my Mac and SSH connection, but I don’t know anything about navigating/creating files and folders via command lines. Somebody could help me to understand the functioning and/or to guide me step by step for the installation of the plugin?

EDIT: I dowloaded the fil on the github repo.

Thanks in advance for your answers. French spoken accepted :smiley:

N.B I’ll post some pics of my « futuristic teabox case » when it will be completely done.

Make life simple for yourself … set up a hotspot on your phone and connect Volumio to it. Download and install your plugins from the UI,

I tried. I can’t access to webUI when connected to Android hotspot. Not sure to understand why… Something like Android security, hotspot limitations…
I need a screen for this, so I need the screen plug-in…

Ok, all my apologies. It was an address error. Solved with MDNS browser. Really sorry.

So, my touchscreen is working. Everything is fine.

I plugged an IR receiver. This one:
It is plugged on a Boss Dac. (Tech specs for pins used:
And I have this tutorial for install:

So: IR TSOP is on GPIO17(pin8), LED 1 is on GPIO22(pin14), LED 2 is on GPIO27(pin10), 3v3 pin 3 and GND pin15.

I changed my config.txt file like in the tuto:

And then, when I want to go to: /etc/modules it tell me that i2c-dev doesn’t exist.

volumio@mikhifi:~$ sudo /etc/modules /etc/modules: 7: /etc/modules: i2c-dev: not found volumio@mikhifi:~$

I think the GPIO out pin is not the good pin specified in the config.txt then it doesn’t recognize it. But I don’t know to which pin “GPIO out” corresponds.
I’m a bit lost… Can anyone help me?

I assume here you are referring to the pinout of J19 of the Boss DAC(?).

So before connecting the IR receiver the i2c-dev entry has been there?

I don’t see what the gpio_out_pin=7 setting would be needed for as the IR module seems to be a receiver only. Though I don’t watch a conflict of gpio_out_pin 7 (which would be hardware pin 26 on the RasPI) with the pins used by the Boss DAC you may try removing ,gpio_out_pin=7 from the line with dtoverlay=lirc-rpi…

Also the lines regarding the Volumio i2s settings #### Volumio i2s setting below: do not alter #### dtoverlay=boss-dac-pcm512x-audio seem to be doubled for no reason(?). I would check if removing one of these entries from the /boot/config.txt would solve the problem.

Yes, absolutely.

I don’t think so. To be honest I don’t understand what it is. I did some research about i2c but did not find anything clear for me. :blush: I found this: Maybe it can help.
Anyway there is nothing about that in the nuxii tutorial; maybe they think it’s an obvious handling to get it that it’s not useful to mention… But not for me…

I totally agree with it.

Ok, I will test that and will return to make you a report.
Thanks a lot.

Same issue. As I expected.

I surely need something else in connection with i2C pins. I continue my research; if you have any other suggestions… I’m thinking about deporting the Boss card to get access directly on the rpi’s GPIO as @cldebuhr suggested on the other thread linked in my previous post.

Thanks again.

Just for clarification: Does the Boss DAC work (with/without the IR receiver connected)?

Also what is the version of your DAC?

To further narrow down I would remove the Boss DAC and test the IR receiver connected directly to the RasPI.

Yes it’s working. It’s the v1.2. Plugged to its own psu.

I can try that too.

Ok, I’ve got some news. I just plugged the IR receiver directly on the raspi. Nothing else plugged(no screen, no DAC…).
After update, I typed the following line, as mentionned in the tuto:

volumio@mikhifi:~$ sudo /etc/modules /etc/modules: 7: /etc/modules: i2c-dev: not found
Same response.

But I read that i2c bus is already on by default in volumio; and when I go to this file:

[code]volumio@mikhifi:~$ sudo nano /etc/modules

GNU nano 2.2.6 File: /etc/modules

/etc/modules: kernel modules to load at boot time.

This file contains the names of kernel modules that should be loaded

at boot time, one per line. Lines beginning with “#” are ignored.

So it is of course activate. Wrong?

After I tried this command line (found in a raspbian tuto to detect i2C activated bus):

volumio@mikhifi:~$ sudo i2cdetect -y 1 0 1 2 3 4 5 6 7 8 9 a b c d e f 00: -- -- -- -- -- -- -- -- -- -- -- -- -- 10: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- 20: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- 30: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- 40: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- 50: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- 60: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- 70: -- -- -- -- -- -- -- --
Nothing’s alive…

So what? My IR receiver doesn’t work?

Ok, at least we can say it was not the DAC :wink:

Did you install lirc (sorry for asking the obvious) and what are you doing to test the IR receiver?

What is the output of lsmod and ls -l /dev/lir* ?

Please also post the content of /etc/lirc/hardware.conf cat /etc/lirc/hardware.conf

ERF my raspi PSU just died :imp: I don’t have anything to replace it for now so I have to fix this problem first… I’m gonna buy a true PSU and not a phone charger. It will be better.

To answer your question: yes I installed LIRC, and to detect IR Receiver I just typed this command line: sudo i2cdetect -y 1 Because of it is plugged to 3v3 and GND I thought it would detect at least the current which crosses resistances…

I don’t think i2cdetect will show anything regarding your IR receiver as it is not connected to any I2C related pins (SDA1-I2C => pin 3 and SCL1-I2C => pin 5). As far as the tutorial ( mentions I2C to me it seems the reason is that the tutorial had an LC display in mind which would be connected via I2C.

According to the Boss DAC manual the DAC uses I2C.

So! After almost a year I finally found the time to work again on my project. My PSU works but when the previous died, it killed my rpi AND my DAC :imp: :imp:
I don’t have my DAC at the moment, but I’ll deport it to get acces to the gpio. So I’m working on my IR Receiver now.

I restarted all the ir config given in this tuto( and i’m blocked at this state:

irrecord -n -d /dev/lirc0 ~/lircd.conf

(Here was the good syntax I have to use. The one given in the tuto doesn’t work: irrecord -f -d /dev/lirc0 /etc/lirc/lircd.conf )
When I push remote buttons it doesn’t do anything. And after a few moment I have this message: irrecord: no data for 10 secs, aborting irrecord: gap not found, can't continue

So it seems that there is actually a problem with my receiver.

To answer to gvolt:

root@mikhifi:/home/volumio# lsmod Module Size Used by xt_REDIRECT 16384 1 nf_nat_redirect 16384 1 xt_REDIRECT xt_tcpudp 16384 1 iptable_nat 16384 1 nf_conntrack_ipv4 16384 2 nf_defrag_ipv4 16384 1 nf_conntrack_ipv4 nf_nat_ipv4 16384 1 iptable_nat nf_nat 32768 2 nf_nat_redirect,nf_nat_ipv4 nf_conntrack 126976 4 nf_conntrack_ipv4,nf_nat_ipv4,xt_REDIRECT,nf_nat ip_tables 24576 1 iptable_nat x_tables 32768 3 ip_tables,xt_tcpudp,xt_REDIRECT brcmfmac 307200 0 evdev 24576 1 brcmutil 16384 1 brcmfmac joydev 20480 0 cfg80211 573440 1 brcmfmac snd_bcm2835 32768 0 hid_multitouch 20480 0 snd_pcm 98304 1 snd_bcm2835 snd_seq 69632 0 snd_seq_device 16384 1 snd_seq snd_timer 32768 2 snd_seq,snd_pcm snd 69632 5 snd_seq,snd_timer,snd_seq_device,snd_bcm2835,snd_pcm rfkill 28672 2 cfg80211 i2c_bcm2835 16384 0 lirc_rpi 16384 0 lirc_dev 16384 1 lirc_rpi fixed 16384 0 uio_pdrv_genirq 16384 0 uio 20480 1 uio_pdrv_genirq i2c_dev 16384 0 fuse 110592 1 ipv6 425984 60 squashfs 40960 1 overlay 73728 1

root@mikhifi:/home/volumio# ls -l /dev/lir* crw-rw---- 1 root video 243, 0 Jul 22 10:26 /dev/lirc0

And: cat /etc/lirc/hardware.conf I used parameters given in this thread:

[code]# /etc/lirc/hardware.conf

Arguments which will be used when launching lircd


#Don’t start lircmd even if there seems to be a good config file

#Don’t start irexec, even if a good config file seems to exist.

#Try to load appropriate kernel modules

Run “lircd --driver=help” for a list of supported drivers.


usually /dev/lirc0 is the correct setting for systems using udev


Default configuration files for your hardware if any


I also found this command line: mode2 -d /dev/lirc0
To test the remote control. This one makes my terminal loose the control of my rpi:

[code]root@mikhifi:~# mode2 -d /dev/lirc0
sudo reboot

At this state I can’t do anything. The remote doesn’t do any changes and I have to restart the terminal to get ssh access again.

Any idea? :frowning: