TL-WN8200ND (rtl8192cu) wifi dongle doesn't work!

I’ve purchased the TP-Link TL-WN8200ND high-power wifi-dongle because I had some trouble with signal strength for my Cubox-i2 running Volumio 1.5. The chipset of this dongle is rtl8192cu. I’ve read here that rtl8192cu is supported from version 1.55 on upwards (hopefully). I connected the dongle to the Cubox and switched off the MAC filtering on my modem. However, there is no signal detected, and no IP assigned. I left the settings on the Cubox for the connection as they were with my old, low power dongle. The light glows green on the TL-WN8200ND. I am quite a layman. What should I do?

My /etc/network/interfaces:

[code]auto lo
iface lo inet loopback

auto wlan0
iface wlan0 inet dhcp

wireless-power off

wpa-ssid “ssid”
wpa-psk “psk”

auto eth0
iface eth0 inet dhcp

lsmod contains:

rtl8192cu 103861 0 rtl_usb 19576 1 rtl8192cu rtlwifi 92194 2 rtl_usb,rtl8192cu rtl8192c_common 74324 1 rtl8192cu

Does the driver work with Volumio 1.55 on a Raspberry Pi?

I had a similar problem. I had a basic wifi dongle which loaded and worked under raspbian but would not work with either Volumio or Musicbox. I tried a number of other wifi dongles and none worked with Volumio or Musicbox.

I tried the wifi dongle which came with my Oppo 95 and it worked. I now have two EDIMAX wifi dongles which are the ones suggested for the Pi on the way. I’m hoping they will work with Volumio.

Also I can’t access any more than one USB RAM stick in Volumio but could in Musicbox. But Musicbox would not easily recognize Hiberry+ DAC.

any clues about the RAM sticks?

Do you see available networks by using “sudo iwlist wlan0 scan” ?

Try following the instructions here: … (especially under “ADDING THE NETWORK DETAILS TO THE RASPBERRY PI”)

I get this:

[code]volumio@volumio:/$ sudo ifup wlan0
Error for wireless request “Set Power Management” (8B2C) :
SET failed on device wlan0 ; Operation not supported.
Internet Systems Consortium DHCP Client 4.2.2
Copyright 2004-2011 Internet Systems Consortium.
All rights reserved.
For info, please visit

Listening on LPF/wlan0/xx:yy:zz:xx:yy:zz
Sending on LPF/wlan0/xx:yy:zz:xx:yy:zz
Sending on Socket/fallback
DHCPDISCOVER on wlan0 to port 67 interval 6
DHCPDISCOVER on wlan0 to port 67 interval 5
No DHCPOFFERS received.
No working leases in persistent database - sleeping.
and ifconfig is not recognized as a command.

In my case it didn’t even recognise the wifi card. Different with the Oppo dongle.

Things are getting pretty freaky out here: Now I purchased a Raspberry Pi and installed Volumio 1.55, and now the TL-WN8200ND IS working, but the signal strength is about between 3% and 10%! Mind you, this is a high power dongle!! So I tried my luck with my old dongle, and now suddenly, with the Pi, its signal strength is 100% where is was about 50% with the Cubox!! What is going on here??

Well, I am really happy for as long as it lasts! :wink:

BTW, now the signal strength from the modem to the dongle is only 14% according to Volumio! It seems that there are a lot of things that can go wrong depending on the setup!

Since the signal strength of my modem is constant at 14% according to Volumio, I suspect this is a misrepresentation of a signal strength of actually 100%. Furthermore, I suspect that a high-power dongle needs special care and hence some adjustment to the current software. :wink: (I am currently using a normal dongle)

I am up and running for an hour or two now.

Mine is at %14 too :slight_smile: and its placed behind a stack of 40cm x 15cm x 40cm amp and a cd player of the same size.

Sent from my iPhone using Tapatalk

It seems that Volumio somehow has the power regulation of the WiFi-dongles the wrong way round, or something…

It sounds like your high powered wifi adapter needs high power to work.

Ifconfig needs to be started with sudo

It’s possible that the driver is in the raspberry pi version but not in the cubox version.