Above hardware came last week and I’ve been trying to get it running since. Build went fine. Installed Volumio on Tinker to eMMC memory. Volumio boots fine and finds my music on USB. Crappy Sound outputs from Tinker HDMI to my receiver but not through any HiFiBerry output.
On the Volumio config page, HiFiBerry Digi+ Pro never displays in the Output Device or DAC Model (with I2S enabled) sections.
aplay -l doesn’t list it. The only devices listed are Tinker’s onboard USB ports.
I tried to manually add a dtoverlay for it to hw_intf.conf. No luck. I checked /boot/overlays for the driver. I see hifiberry-digi-pro.dtbo which I assume is the right driver.
I tried adding explicit references to HiFiBerry Digi+ Pro in /boot/config.txt.
Dmesg log reports always reports that it is unable to start the selected IS2 Dac.
I though it might be a bad Digi+ Pro, but the HifiBerry Dev team thinks Digi+ Pro is not supported on the Tiker/Volumio platform.
Can you please share your thoughts on my dilemma, especially as to next steps for troubleshooting? Will pick up a Ras Pi board today to see how that works.
Thank you.

I have just checked the list of i2s devices which are offered as a choice in the i2s DAC configuration for the Tinkerboard.
You are correct, the HiFiBerry + Pro DT overlay is there, but never got added to the list.

Can you try the following:

go to “/volumio/app/plugins/system_controller/i2s_dacs/”
then edit “cards.json” to add the following line after the hifiberry-dacplus entry near the bottom.
unfortunately it is shown as 2 lines below, but it is a single line, no line-breaks.
(You could also copy the line from the Raspberry section further above,

{"id":"hifiberry-digi-pro","name":"HiFiBerry Digi+ Pro","overlay":"hifiberry-digi-pro","alsanum":"1","mixer":"","modules":"","script":"","needsreboot":"no"},

Then save the file and reboot, then try to configure.

Hi there,
I face the same issue with Tinkerboard s and hifiberry digi+ pro.
I added the code as suggested, it appears now in the menu and I can select it.
But still no output on SPDIF or TOSLINK.
Any idea how to trouble shoot this?
Thanks a lot.