Tidal Connect stops

No issues set to HiFi with other Tidal Connect devices. Just Volumio.

1 Like

Tried setting Tidal to normal, but didnt work, still wont play via tidal connect :frowning:

Will tidal play when ‘play on device’ is selected?

Yep, Tidal works fine unless its using tidal connect to play through volumio. Also, the regular tidal on volumio works fine too

Hope they figure it out soon, its killing both tidal and voumio for me :frowning:

Edit - this goes for both the tidal desktop app and tidal on my S10+

@volumio i also have trouble with Tidal Connect every other song stutters .
here are some info to my system

Pi 3 b+ Connected Via Lan
Wifi is Good (Im Stream / Play VR with it so yeah ^^)
Tidal Hifi
Topping D10 Dac
Location :Germany ISP is a Regional one (Wilhelm Tel )

An update on this issue:

We might have narrowed it down:

It seems to be happening only with some ISP, which either use IPV4 or NAT. This triggers a bug in curl when using http2 mode, after some repeated requests it fails and therefore the player does miss some parts of the tracks. Hence it stops.

Unfortunately it’s just an hypothesis and we are working to disable http2 for TC and other services and test it (luckily, Davide, our QA Specialist has an affected ISP).
This is pretty daunting bug as it’s really really hard to figure out what is causing this.
But we are not sparing any effort.

Thanks for your patience.

For those of you that can, asking your ISP to enable Ipv6 seems to cure the issue for some.

We will keep you closely posted.

1 Like

@volumio my ISP is fully IPv6 enabled, what do we need to do in Volumio for IPv6?

Update: we are testing a promising fix… Fingers crossed…


I am seeing issue with stutters when changing songs and Connect stopping playing

Look at:


Version 3.233 seems to have solved my Tidal Connect problems.

Thanks Volumio!

P.S. For those who don’t know, Test Mode is turned on by going to the following address: volumio.local/dev (“volumio” is standard, but if you changed your device name, enter it in place of “volumio” in the address) and clicking TRUE under Test Mode. Of course, Test Mode is not the official release, so I guess it’s “Proceed at your own risk”.

3.233 seems to have solved my Tidal Connect issues as well.

1 Like

Yes, the lastest release seems to be better. I still get a little stutter when changing tracks at the beginning of a song. And darn IOS won’t show Tidal Connect playing on lockscreen. It does with Spotify Connect whuch still works more smoothly than Tidal

I am happy to report that the latest release solved my Tidal issues completely. I run Volumio on an RPi4 to SMSL SU9 DAC. Flawless operation since the update was installed.

Unfortunately it’s still happening for me. RPi 4 USB to iFi Zen DAC. I’ve tried the DAC with USB power and external power with no difference. UK ISP PlusNet. I can normally just reconnect to TIDAL Connect in the app and press play, but it will usually stop again very soon. I even tried Test mode to install vers 3.251 but it still happens. Most recent log: http://logs.volumio.org/volumio/xpS4QAS.html.

By examining your logs I see that the DAC disconnects and re-connects very often.

It’s like if the DAC is disconnected phisically and then reconnected…

This (but it’s just an assumption) might indicate that the DAC USB receiver is crashing and restarting itself many times.

2 suggestions:

  1. Check the USB cable, and maybe try to use another one
  2. Check if the DAC firmware can be updated

Let us know

That’s great, thanks very much. I’ll check into that and let you know.

Just to update - I updated the firmware and switched the USB cable, from the USB3 one supplied with the unit to a USB2 one from QED. It’s been playing literally non-stop today, so I’m very happy!

Thanks for the suggestions, and the great software!

Great to hear!

This Also happened to me, reboot DAC and reinserted usb. Fixed it. Thanks