Tidal connect, raspberry pi zero w, wifi issues etc


  • Raspberry Pi - zero w (1)
  • DAC - InnoMaker (allo boss)
  • Volumio - 3.3.01
  • Tidal - (android)
  • Premium - day 7 of a 15 day trial

While streaming Spotify or Tidal, the CPU hovers between 35% - 70%, while memory is consistently at 100M - 140M. I realize the pi zero may be CPU bound sometimes, but it’s mostly doing ok (I’ve since ordered a RP 4, 2G mem).

1.) I can connect/log in to Tidal.com via Volumio and stream tidal music through the Volumio software; however, I cannot connect to Volumio from the Tidal android app. Additionally, the highest quality I can stream is 44.1Khz/16bit.
2.) While all other computers and devices remain connected to the wifi access point, RP0 drops randomly and regularly. I’ve used this RP0 for numerous projects without this issue.

I would consider paying for Volumio if I could resolve these issues. I believe adding more cores will improve serving the web-tier, but I’m skeptical that it will address wifi and the tidal issue

Any pointers would be greatly appreciated.

With respect and gratitude,


the first model of the RPi0 is really too slow for all those features.

I recommend to get a new RPi0-2, it has a quad-core processor and it will make Tidal working without problems (tested personally)

1 Like

hi Bill!

Most Tidal tracks are going to come through at CD quality like you have reported. The highest I’ve been able to achieve is 48/24 bit even though the Tidal master is 192/24 and my DAC supports 192. I’ve made peace with it, since my DAC does not do MQA unfolding.

I get 48/24 when available by setting MQA on in Volumio - Sources - Tidal (even though my DAC does not support MQA).

I’ve also switched from a Pi Zero 2W to a Pi4b and Volumio runs much better as an endpoint now.

Endpoints not showing up has been due to networking / dns in my experience. Switching to wired networking only on the Pi4b solved my issue - as well as making sure your phone and volumio are on the same subnet of the network.

Thank you Darmur. More cores, more performance/function. Makes sense. Thanks for your suggestions, I appreciate it.

1 Like

Thank you timmee. This is my first foray into the world of high-quality audio/streaming. The explanation of MQA and expectations of Tidal is helpful.

I’ll verify and address issues with my network settings. The one thing I’d add is that Spotify sees Volumio and streams as expected.

Thanks again.

Tidal HIFI is max CD-quality (16/44), Tidal Masters is Hi-Res (but most is still max 16/44) - but only if you have hardware that supports MQA. Volumio does not support MQA, but it can do passthrough.

You can also try Qobuz, no special hardware needed for Hi-Res.

I went ahead and spent way to much money for a 2G RP4, and I can now connect to tidal…which is great. I suppose one core just isn’t enough to load the plugin.

I’ve tried QuoBuz streaming service, and its “master” audio streams are pretty impressive sounding. I can hear the difference…it’s awesome. But now, the Quobuz doesn’t see the volumio target. I need to crawl through the logs and see what’s causing the problem.

I appreciate everyone’s suggestions.

Respectfully yours,


1 Like

You have to use Qobuz via the Volumio app or Web UI for the foreseeable future. Qobuz has a similar function to Spotify Connect and Tidal Connect - but they seem to at the moment only support a very limited selection of streaming hardware/software.