Tidal Connect playback is erratic

I am evaluating Tidal Connect on my RPI3 with Allo Digi.
Problem: Playback randomly stops and I have to hit either Previous or Next on Tidal App to get it going again. When playback stops, Tidal app spins the play button and Volumio app seems to lose contact with the device.

Here’s a live log:
I note a number of asio errors. I’m assuming the Primo Player is running identical Volumio,
is this so?

 volumio endpointstest 
https://google.com, 5143 ms: FAILED
https://www.googleapis.com, 5120 ms: FAILED
https://securetoken.googleapis.com, 531 ms: OK
https://myvolumio.firebaseio.com, 536 ms: OK
https://functions.volumio.cloud, 5114 ms: FAILED
https://oauth-performer.dfs.volumio.org, 857 ms: OK
https://browsing-performer.dfs.volumio.org, 958 ms: OK
http://cddb.volumio.org, 5645 ms: FAILED
https://functions.volumio.cloud, 5789 ms: FAILED
http://pushupdates.volumio.org, 5108 ms: FAILED
http://plugins.volumio.org, 5108 ms: FAILED
https://database.volumio.cloud, 5107 ms: FAILED
https://radio-directory.firebaseapp.com, 5107 ms: FAILED
WARNING!!! Some remote endpoints cannot be reached!
Failing endpoints: 
https://google.com, 5107 ms
https://www.googleapis.com, 5107 ms
https://functions.volumio.cloud, 5107 ms
http://cddb.volumio.org, 5107 ms
https://functions.volumio.cloud, 5107 ms
http://pushupdates.volumio.org, 5107 ms
http://plugins.volumio.org, 5107 ms
https://database.volumio.cloud, 5107 ms
https://radio-directory.firebaseapp.com, 5107 ms`

OK, bunch of endpoint failures.
Would you care to offer some explanation or even solutions?

it’s timing out after 5107 ms it could be some network problem.
did you reboot already? some times it helps
i would try the next beta this version has a lot of problems.
ip/dev set test mode on true and try to update it should you give the latest.

yes, wi-fi upstairs may be weak today.
my Bluesound Node2 performs a lot better but now it too is misbehaving;
plays one tracks and stops. its diagnostic page shows wifi signal to be “weak”.

thank you for your response!

dvo’s excerpt of your log shows that your device is having problems accessing a number of general internet endpoints eg. ‘google.com’. I see that you are using wifi … is it possible to check if your internet connection problems are wifi based ie. try a wired connection if possible.

Edit: just seen your reply. RPi3 wifi has a bit of a reputation for being a bit poor. Do you have a USB wifi dongle if you can’t connect by ethernet?

planning to install a mesh router with couple of satellites.
and use wired connections. hopefully that’ll bring better stability.
thanks for your comments…

FWIW, I’m seeing this same behavior on a wired connection.

Just randomly stops playing. But skipping tracks ahead or back fixes it.


post your log and we will see if it’s the same.

I am now using wired ethernet for RPI4 and internet connection is solid. Yet, at this point, Volumio starts to play and stops within seconds. Bluesound Node2 was working a lot better. But this pm, both were basically non-functional as Tidal Connect devices.

It’s important to note that both devices had no issues streaming using their built-in Tidal support. So it looked to be like Tidal Connect problems at Tidal server end. This is pretty crazy behavior, I really don’t know what to make of it… I’ve sent the log to Volumio as well as submitted a report to Tidal.

I plan on another week or so for some answers or solutions. If not, I guess I will return to Spotify. For sure, there were no issues with Spotify Connect. I even have my own app written using their public web api. But I like Tidal app on android for UI and audio quality.

I am experiencing exactly the same problem.
I am on RPI4

i have this problem with tidal connect. it’ll play a few songs and then just decide it doesn’t wanna play anymore. i have to either skip forward to the next song or backwards to the previous song for it to resume. i’m on an RPi4. no issues whatsover with spotify connect.
rpi4, 7in touch screen, topping d30 pro.

Hi guys

Thought I’d ask here instead of starting a new thread.

For some reason, I’m getting this error whilst using the Tidal (android) app and trying to play something through Tidal Connect.

failed to connect to server. check your internet connection or go offline

Wondering if it’s an issue with the Tidal app or server, able to play via PC.

Thanks in advance!

Same issue here with Tidal just stopping. Sometimes can get thru a couple songs but then stops and have to do the skip fwd/bck to get it to play. I was going to pull some Cat6 and move from wifi to hardwire but it seems it didn’t fix the issue for others. I want to love Volumio using Tidal Connect and its almost there. just gotta find a way to stabilize playback. Watching to see if we come up with something on this thread.

Added myVolumio Premium solely for the Tidal Connect integration. Also experiencing this same issue. Bummed it doesn’t work.

thanks to the help of TIDAL team, we are making progress in finding what the issue is.
Rest assured that we are very determined to fix it ASAP

Sorry for the inconvenience


Same problems here. Fresh upgrade, Pi 4 about 2m from AP, etc. Also posted in the main Adding Tidal Connect thread.

Any updates. This is unusable and extremely frustrating.

This problem is still not solved for me.
Did anyone get it to work normally?

Ditto, this problem still exists in the latest update when playing via Tidal Connect (say from your phone Tidal app etc.) but have found it plays fine if you are playing directly from Tidal inside Volumio

Exactly the same for me.
Tidal works.
Tidal connect frustrates.