Tidal Connect from Android Tidal app doesn't work


2 posts below hold potential solutions:

  • clear Tidal app cache, relogin into it or reinstall it (in my case only the last step worked)
  • wait till the end of September for a fix from Tidal

Brief description

When I select Volumio in Tidal Android app, the speaker icon briefly flashes, and turns back white. I wasn’t able to make it connect today at all.

Hardware and software

Volumio Version: 3.324
Hardware: Raspberry Pi 3… b?
DDC: Pi2AES Pro Audio Shield - a hat sitting on top of R Pi. In Volumio settings I selected the DAC model “HiFiBerry Digi+ Pro” for it to work.
DAC: Topping D90 connected via IIS over HDMI
Tidal Android app version:

Debug log


Steps to Reproduce

  1. Tidal Connect used to work a week or two ago. I didn’t check since then. I didn’t change anything in the settings. Volumio was logged into Tidal and Tidal Connect option was enabled in the settings. Tidal Connect could see Volumio.
  2. In Tidal Android app click loudspeaker icon. Select Volumio.
  3. The screen goes back to a song. The speaker icon briefly flashes, and then turns back white. Connection doesn’t work.

Additional Information

My Volumio previously had different problems. After each reboot there was a risk it wouldn’t work. So, after a few months I changed the SD card to a much better one, as it was pointed out to be a possible cause. I flashed the card, configured the fresh Volumio installation and used it for, perhaps a few weeks. I only use it as a Tidal Connect device.

Today, along with the problem described above, Volumio also couldn’t play songs from Tidal . Browsing worked. After some fiddling, integration with Tidal started working again, but Tidal Connect didn’t.

Things I tried:

  1. A few reboots of Raspberry Pi, Volumio and Tidal Android apps (used Force stop option in Android).
  2. Disabling and enabling Tidal Connect in Volumio settings.
  3. Relogged into Tidal from Volumio. After login I received an error: -2 net::ERR_ADDRESS_UNREACHABLE.
  4. After another Raspberry Pi reboot integration with Tidal started working. Tidal Connect still didn’t. I tried some additional things.
  5. Changed the primary DNS to, and back to automatic.
  6. Disabled WiFi (Raspberry Pi is connected via Ethernet).
  7. Changed streaming quality settings and MQA.
  8. Before sending the debug log, I tried connecting from Tidal multiple times.

I was having trouble with Tidal Connect recently also.
I fixed it (at least until it acts up again) by clearing the cache and data of the Tidal App (Android).

I had to re-log into theTidal app, but Tidal Connect was working again.

1 Like

This is an issue with the Tidal app. Tidal has fixed the issue, the fix will be released September the 21st.


:rofl: almost 3 weeks from now. Great. I’ll mark your response as a solution. But if it isn’t fixed by the end of September, I’ll be back :sunglasses:

1 Like

Ok. I solved the issue for myself. I cleared the cache, user storage in the Tidal app. Then I logged out. When all that didn’t help, I reinstalled the app. Then it started to work. It’s the same version though.


Awesome! Clearing app data seems to work, but is super annoying and not permanent. Entails redownloading content if used. Hopefully this also resolves the pause-button-spinning-can’t-stop problem.

I’ve tried all of the above fixes and it still bugs out. Tidal Connect only works from my desktop computer and laptop, not my Android phone.

RPI4 8gb with Volumio Version 3.324
Samsung Galaxy S21 Android Version 12
Tidal Version

Have noticed this stopped working on Android Tidal app too (pixel 5)…
EDIT: force stop, clearing data & cache seemed to fix it… all good :smiley:

Ps. Network controls seem to come up now (intermittently) on the lock screen, pretty cool. Can’t always replicate it so dunno about it.

This still isn’t fixed with the current app version 2.68 unfortunately. Anyone else still having issues?

Mine’s been working fine since the last android Tidal app update.
App version

That is good!

I continue to have difficulties sadly, no idea why. On a Pixel 5.

Same here, havent worked for over a month now. reinstalled Tidal and still doesnt work.

Edit: now i have tried a fresh install of both tidal on my android phone and i new fresh install on my tinkerboard and still cant see my volumio device in tidal on phone or pc. i have virtuoso subscription.

edit2: read the other thread that you are aware of this problem and working on it. in my hunt for a fix i upgraded to premium subscription. is there any chance you can roll back this for me to virtuoso?

hi guys,

not sure of the correct place to ask, but i’ve noticed Tidal Connect has dropped off on the Windows (10) App - as in there is no Volumio output sound device. I’ve tried a reinstall. Still works on Android app.

Any ideas?


I’m having issues with Android / Tidal connect. Seems very good when it works then just stops working for no reason. Usually Tidal app says that volumio is connected via tidal connect but no music and I can’t select other outputs e.g. " this device" or pause / play music.
I’m using Pixel 4a with latest Tidal app, Pi 4 networked via Powerline adapter with latest Volumio version, USB out to Q Acoustic M20.
Any thought gratefully received as it’s starting to get annoying!

I am having exactly the same issue. Setup:
Phone: Google Pixel 6 Pro (Android 13)
Tidal App: 2.73.0
Raspberry Pi 3B+ with HiFiBerry DAC2 HD
Latest Volumio Version.

The HiFiBerry DAC2 HD is definitely not related to this, as the issue also exists when using the standard jack.

Is there anything I can do to support the investigation?

Have had this problem for several months. Before it was neccessary to do delete data / cache and force stop. Now force stop only is enough.

Same behaviour as @Euan_Hamilton-Rigg described.

Phone: OnePlus 10 Pro (Android 13, was same with 12)
Tidal App: 2.74.0
Raspberry Pi 3B+ with HiFiBerry DAC plus
Latest Volumio Version.

1 Like

Logs when problem active http://logs.volumio.org/volumio/IaowLtl.html

Ok, I think I was able to solve the problem. I have been listing music for about 2 hours - tidal connect is working flawlessly. The solution was to disable battery restrictions for the Tidal app in Android.

Settings > Apps > Tidal > Battery > select “Unrestricted”

This reddit post gave me the answer: Link

Can someone confirm?

This makes sense as a fix, because when using tidal connect you are not playing media locally on the phone so the battery optimiser will kick in.

Looking at the phones of people who checked in here, Samsung and OnePlus these are one of the worst in terms of how aggressive the battery optimiser is.

From here you can find how to put the settings for different brands and android versions https://dontkillmyapp.com/

Yes, makes sense. But as a side note, spotify-volumio and tidal-google cast works.

Even though they might disconnect, but reconnecting to device just resumes the app whetr it is actually going.