There is no sound through the hdmi cable

Volumio Information

Volumio: Volume version 2.873
Hardware: foxconn brazos at-5570

Hi guys I have one question about the sound.
I connected the computer via the HDMI cable to the TV picture, but the sound will not play via the HDMI cable, but only the analog signal.
Here I am sending a log file to see which sound is in question.
I am asking for a solution to this problem of mine without having to buy some external DAC

Not sure if this will work. Do you get “HD-Audio Generic” as a choice in the playback options?

Could you open a terminal (Ctrl-Alt-F1 with volumio/volumio) and do
amixer -c 0 set IEC958 unmute

It unmutes SPDIF, please let us know if that helped.
Also, it seems it has a mixer called “ATI R6xx HDMI”, could you run
to modify the mixer settings while playing something? You may have to try a few things there.

Nothing helped to get the sound over the hdmi.

Very unfortunate, but there is nothing else I can do.
There are many, many different X86 device out in the field (unlike the PIs which are all configured the same way), which makes it impossible to support them all with all their outputs.
Especially with not having a sample onsite.

Hi, have you clicked on your computer’s Sound Configuration Settings? I access it by right clicking on the volume icon and a box pops up with “Audio Output,” then “Audio Input”, and then “Device Profiles.” Click on that one and another box opens with your different available outputs with selection boxes below each one.

Clicking on the HDMI selection box reveals two options (for me): “Digital Stereo Output,” or “Off.” Obviously, it should be the former. My setup had defaulted to “Off.”

I hope this helps,

Let me ask you if you installed Volumio on Windows or as a separate program. My volume is separate and I don’t have that option you offer me.

maybe a little far seeked but hdmi could use the touch display plugin ?
and if you set output to hdmi it could work…

Uploading: Volumio 2.jpg…

sorry your on a x86 then you will have other options …gkkpch gave you the right anwser use aslamixer
and enable it there