The use of USB speakers and Volumio

I have the following problem: I have a harddisk full of music, a set of USB speakers (Logitec Z cinema), but no spare PC to connect the two. So after some browsing on the www the solution I came up with was to buy a Raspberry Pi, install Volumio and hook it all up.

However having done this I cannot manage to get music files to play (and hear the music over the speakers), however I can get music to play and hear over my headphones if I select the ALSA output. So at the moment I am sure that the RaspberryPi works, Volumio functions, my head phones work, and that the the USB speakers work as I checked them, but that something goes wrong in between.

Can someone help me with this problem, as I don’t know if I can solve it by changing the settings in Volumio (I tried a fair bit) or if this is a non-solution in the first place (with Volumio, or any another raspberry pi operating system).

I tried to find answers to this question however I could not manage to find something satisfying. Any response would be greatly appreciated, and I am sorry if someone asked this question before.

Kind regards,

I know this isn’t the answer you want, but I would seriously suggest just getting some speakers with a normal connection instead of USB speakers. After all, this is an audiophile music player and USB speakers aren’t going to be the best quality. :slight_smile:

Presumably you want the USB speakers to be your output? Do they show up as an available output when you type the ‘alsamixer’ command? Or ‘aplay -l’?

I would like the USB to be the output indeed.

Re the alsamixer command: so far I only worked with “volumio.local/” this because when I connect USB speakers and a hard disk there is no empty USB slot left on the Raspberry for a keyboard - so I did not connect the raspberry to a monitor/tv & keyboard. In the volumio.local framework there does not seem to be an option to write command lines (is this correct?). So at the moment I assume that your suggestion only works if I connect the raspberry to a monitor/tv+keyboard (with Volumio as an operating system).

However, having that said, at the moment the speakers do show up in the output menu on “volumio.local/” as something like “cine?ma” (the name of the speakers is Z-cinema so I assume this corresponds, as well as the ALSA option). But when I select the “cine?ma” option, the audio files do not play. There is an estimated duration of the track, but when I press play the file does not play (and there is no music). When I select the ALSA option the file does play and I hear music over the headphones.

No, my question was based on the assumption of you accessing the Pi via SSH (over the network), from your main computer (or some other computer). That would give you a command line, where you can type commands like ‘alsamixer’ and ‘aplay -l’. Depends what operating system you are using on your main computer. On Windows to use SSH you could use a program like ‘Putty’. On Linux you just use the ‘ssh’ command.

‘alsamixer’ will show you a (basic) graphical representation of your available outputs. ‘aplay -l’ will give you a text-based list of outputs.

Oh I just realized this is a few months old you probably realized by now that the first thing he said is he does not have a PC of any kind just maybe an Android phone and a raspberry pi and external hard drive and USB speakers and headphones.

As far as I know there are no USB speakers that work directly with volumio on a raspberry pi.

It should be simple power and music input on the right box 3,5 mini jack input/output female there should be 2 mini jacks female one is headphone out and one input. Most of the time the bottom one is input
( With the sub d connector ( if this works without the usb connected ))image

The one with the note sign is your input …

Btw this is later added in the controller unit of all the logitech z series.
On the side of the controller unit.

I don’t understand the issue here. A lot of people connect their DAC to the RPi USB. If you plug in a USB speaker instead, it should just work.

It could be that the remote it has a logo of windows media center
So it could be that some part will not work on linux.

But this post is from 2014 so replying on it was a bit stupid.

If you wanna laugh you still can buy it on amazon

We just keep the forum uptodate :slight_smile:

More than a few months — you resurrected a zombie thread from over 8 years ago.
It might have been Volumio version 0.5 at the time :grin: