The 5.10.95 x86 kernel headers are broken

I got it here

But when try to install, this is what I got:

volumio@volumio:~$ sudo dpkg -i linux-headers-5.10.95-volumio_5.10.95-volumio-1_amd64.deb
dpkg-deb: error: 'linux-headers-5.10.95-volumio_5.10.95-volumio-1_amd64.deb' is not a Debian format archive
dpkg: error processing archive linux-headers-5.10.95-volumio_5.10.95-volumio-1_amd64.deb (--install):
 dpkg-deb --control subprocess returned error exit status 2
Errors were encountered while processing:

I tried with older version 5.10.92 and it worked so …


Volumio Information

Volumio Version:

Debug Log

Steps to Reproduce

Additional Information

Your issue title was updated slightly as there is nothing wrong with the kernel :wink:
The header .deb build is part of the normal make process, no idea how that could go wrong. There is no way to correct this either.
I will push it to the repo again on Monday, perhaps something went wrong while transferring the last time.
Otherwise you will have to wait for the next Volumio version, sorry.

If I may ask, what are you compiling?


Sorry about the title, I should think a bit more careful when typed it.

I think I will wait until Monday for the deb. I was trying to compile driver for my usb wifi.

which wifi chip ?
Since 5.10.95 I support a few ac1200/1300 dongles which needed dkms before

Please PM me, when you have a link to proper sources, I can add them to our kernel tree so you would not need to compile your own.
We can only do that since the Volumio x86 version with kernel 5.10.95

Mine is tl-wn725n.

That does not say much, TL-WN725N has several revisions with different chipsets (RTL8192CU and RTL8188EU).
RTL8188EU, RTL8188CUS and RTL8192CU are working fine with 5.10.95

Which version/ revision is yours? Or better, could you use SSH and do

inxi -n

and post the result here?