TerraBerry DAC3 driver

Hi, thank you for supporting this board with volumio v. 2.712 !
i realized that this board is louder than all other i have.
i even turn software volume control on and set to 1 (of 100) sound is at normal room volume level…
i thing this driver should have a correction implemented.

Also i have the message:
The selected output device is not available
Please connect Terra-Berry DAC 2/3 to the unit…

or is here something wrong with my new TB3 ?
Thanks in advance

Hi Jens,

1.) Unfortunately i do not yet have a TB3 here for testing, (No budget atm, just afforded a used Katana + reasonable power supplies - and no sponsor for a trial period…)

2.) I also receive this toast message since ~ v2.705 (beta) on many other test boards - regardless of the used dac. This has been fixed in the past but reappears now. Nevertheless it’s only a message - and everthing is working well allthough. I think this can be just ignored… albeit it’s not “pretty”.

Anyway i want to know what is your first impression ? Worth to buy in this early state of integration ?

btw. i use the TB2 i bought from you at ebay now with reasonable power supplies and an ALLO relay board — great sound. Today i received the Combo386 board and now i will do a little soldering and check out switching between Volumio and USB input :slight_smile:

One day i will meet you in Hamburg, i think…

Best Regards

Hi Josef,
no question - the TB3 sounds great (clear and fine details) to me- so curious about the next soundcheck.
BUT right now i have problems with it. heavy clicks when go in mute. Also, this board is to loud, listening very quietly is not possible.
I clarify this with terratechnos…

Anyway, would be nice to see you too. I know you are around munic. so what about meet us at high-end in munic in may?
best, jens

The heavy clicks/cracks when go in mute are in previous versions with TB DAC2 driver too.
i find out, that only mp3 files shows this behaviour - not flac, etc.

Hi - to keep you informed.
i did get a replacement for my TerraBerry 3 from TerraTechnos.
But still the same issue:
going in ‘mute’ with mp3 files heavy cracks, pops are cooming.
also to loud, even at 1% with software volume.
(this should not a problem if you have a preamp or an integrated amp, with volume control)
I think all this can fix with a driver update!?
so far, have a nice day, j.

with volumio 2.777 even software volume control is not working.
(hardware volume control is not implemented).

the new TB3 is out of stock in volumio shop.

may i still hope that the bug will be fixed or is TB3 support dropped?
Thanks ,j.

update for volumio 2.799
Terra-Berry DAC 2/3 driver is still broken. only 100% volume can be played.software volume control does not work.
TerraBerry DAC works now with generic I2S DAC driver. Software volume control works.
volume can be set from 1 (not hearable) to 100 (loud)
Also the issue with heavy clicks/pops when mute is set with a mp3 track is gone.
so, the new volumio version is somewhat promising for me.:slight_smile:

Correction: it is still too loud. you have to use an volume adjustable amplifier.

Can you show the alsamixer option for the Terraberry when the DAC is properly selected and enabled?

okay. fresh install. Terraberry 2/3 I2S driver selected. reboot. aplay -l shows this:

volumio@volumio:~$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: b1 [bcm2835 HDMI 1], device 0: bcm2835 HDMI 1 [bcm2835 HDMI 1]
Subdevices: 4/4
Subdevice #0: subdevice #0
Subdevice #1: subdevice #1
Subdevice #2: subdevice #2
Subdevice #3: subdevice #3
card 1: Headphones [bcm2835 Headphones], device 0: bcm2835 Headphones [bcm2835 H eadphones]
Subdevices: 4/4
Subdevice #0: subdevice #0
Subdevice #1: subdevice #1
Subdevice #2: subdevice #2
Subdevice #3: subdevice #3
card 2: DAC [I-Sabre Q2M DAC], device 0: I-Sabre Q2M DAC i-sabre-codec-i2c.1-004 8-0 [I-Sabre Q2M DAC i-sabre-codec-i2c.1-0048-0]
Subdevices: 1/1
Subdevice #0: subdevice #0

volumio@volumio:~$ alsamixer
cannot load mixer controls: Remote I/O error