Synology NAS and Volumio

I have a Synology DS1511+ NAS that I can’t seem to get my Volumio to connect to. I have done a number of searches and tried every suggestion I could and still cant get it to connect. I have Volumio installed on a Raspberry Pi 4 and it sees the NAS, but no matter what settings I put in on both I keep getting errors.
On the NAS I have the following configured for my Music folder:

Set for NFS
Host Name: IP of the Pi
Privilege: Read/Write
Squash: Map all users to Admin
Security: Sys
Enable Asynchronous - checked
Allow connections from non-privileged ports - checked
Allow users to access mounted subfolders - checked

In Volumio I have the following:

Alias - Synology
NAS IP Address - IP address
Path - /volume1/Music
File Share type - nfs
user name -
password -

It is probably something simple that I am missing. Any help is appreciated.

Have you set the allowed IP address/range for access to include your RPi IP?

(if you can get to the command line on your RPi, you can check the shares available by typing:

sudo showmount -e NAS_IPaddress

I have the Static IP of the Pi listed under the NFS permissions tab on the NAS for that folder. Volumio see’s the NAS under network drives

1 Like

NFS enabled under ‘file services’? or is this what you meant by “Set for NFS”

Tbh, there are so many settings here that coming up with a definitive checklist is difficult. For example my working Synology NAS has ‘squash’ set to ‘no mapping’, but I don’t recall why I originally set that, but it works, and so I haven’t looked into it any further.

Perhaps you might get more information if you try and manually mount the drive in Volumio at the CLI. You could also look in the system log to see if there is anything there.

Accessing system logs

Yes, I have NFS enabled under file services. I have tried Squash set both ways, no luck. So I should try and mount the NAS as a network drive, similar to how I have it in File explorer in Windows? What is CLI? And thank you for your help, it is appreciated.

Well, I started messing around and it was something stupid. I thought that I hard fixed the IP of the Pi in my router settings to make it easy to access. I looked at the settings on the Pi and the Ip address did not match. I updated the IP on the NAS to match the Pi and hit apply and off it went cataloging all my files.

Glad you’re sorted.

I run a Synology 918+ as a media server for volumio with no issues but volumio’s setup needs a minor tweak…

In volumio’s sources page, in the network drives section, edit your devices setup.
In options area, enter the following: vers=1.0. Then save the configuration.

It took me a lot of searching to find this answer. It works for me, hopefully it will solve it for you.
Good luck,

I had tried that early on with no luck. I did finally get it up and running as I had an error on the IP address. Have another issue now that I have started a new thread on.


The OP was referring to NFS. The vers=1.0 optional setting is for CIFS shares.