Surround sound - SPDIF


How to set up MPD to passthrough AC3 and DTS 5.1 sound? Any idea? Multichannel files are always downmixing to stereo.

mplayer with switch “-ac hwac3,hwdts” works fine.

sound card: Sound Blaster Connect (USB)
connection: Spdif/Toslink
amplifier with Dolby Digital and DTS decoder


Any news on that?

There should be some means to do this.

maybe to much load for the device?

I first installed Volumio to find out it doesn’t handle DTS right.

Then I installed Mplayer, edited /etc/mplayer/mplayer.conf adding two lines in it:


Next killed Volumio watchdog daemon ( and MPD.

Now I can play DTS file fine from console by just giving:

mplayer “file_to_play.dts”

So - if it’s so difficult to make DTS passthrough work with MPD, why don’t you change the player to Mplayer?

Or is it possible for user to decide witch player to use? It would make Volumio far more interesting if it could handle S/PDIF passthrough.

Some more investigation about this matter:

I have two different kind of DTS-files. Some of them have all 6 channels encoded as they are and the others have “stereo” sound as 3 channels are decoded together. 3 * 2 makes 6 channels after my DAC decodes them.

Both these files play as expected with Mplayer, but Volumio does something weird because the stereo files play multichannel as expected but 6-channel files play as 2-channel stereo.

I suppose Volumio is passing 2-channel files through as they are and DAC know how to handle this. Something happends to those 6-channel files, because they are downmixed to 2-channel at the end.

And - once again - all these files play well as multichannel audio by Mplayer. My DAC recognizes them all DTS while played with Mplayer.

Any news on this ?

I just installed volumio 1.5 as I came from a gmrender-resurrect (DLNA) installation that I wasn’t fully satisfied with.
Too long between gaps between songs even though it should support gapless playback.
No DTS/AC3 audio passthrough.
(It was stable enough though.)

gapless playback on volumio is almost spot on… can hear a fraction of a milisecond of silence between tracks.
No DTS/AC3 passthrough … yet, as this thread also indicates.
I can confirm this as well.

Although this trick could be handy for those with DTS ripped audio tracks: … 6&p=489951
(see last comment here.)

apparently renaming a (DTS) WAV file to .flac will trick mpd into passthrough (does not work for ac3 files).

Is DTS/AC3 playback being considered as a new feature for a future release ? Or is the demand for this not that high ?
Any other platform on the PI with a DLNA renderer that supports this ?

My PI is connected to my AVR using the HDMI port.
This means multichannel audio can be passed as either passthrough or as decoded multichannel PCM (LPCM).
Either option will do fine :slight_smile:

I am using the jriver mediacenter (windows) as the DLNA service.
It has a lot of options on what to parse to the DLNA renderer (original, pcm etc.).`

No matter what setting I use, AC3 tracks are played back as 2 channel PCM on my AVR.


small update.

I updated the jriver dlna server.
Once I set it up for PCM 24 I get this in the volumio web admin page under the playback tab:

path: F5946.wav
Playlist position 2/3
Multichannel - 32 bit - 48 kHz

so it seems like its able to retrieve the multichannel PCM audio from the wav file.
although its still rendered as 2 channel pcm.

and outputting the original stream I get:
path: F5899.ac3
Playlist position 1/1
Multichannel - 16 bit - 48 kHz