streaming from Ubuntu (and other Linux) to Volumio

At last, I found how to stream easily from my Ubuntu computer to Volumio. Everthing is here :
To resume :

sudo apt-add-repository ppa:qos/pulseaudio-dlna
sudo apt-get update
sudo apt-get install pulseaudio-dlna

And start it : pulseaudio-dlna
or to send using FLAC codec

pulseaudio-dlna --encoder flac

You should have paprefs installed.
Now, if you go to the volume control, you’ll see all your dlna compatible device, even your Volumio device ! Just select it as output and play ! :smiley:


I have Volumio 1.55 installed on a RasberryPi 2 B.

I’am running fedora 23 LXDE on a netbook, I’ve also installed pulseaudio-dlna from there: ,then i’ve installed paprefs using dnf.

So, finally, whenever I use Vlc or Quodlibet I cannot see/choose the DLNA output, I have no such scroll menu as show on pulseaudio dlna github overview

Thanks for reading this,

If someone have some hints, or want to help, you’re welcome!


Hi Balbuze,

A thousand millions thx ! Amazing topic :smiley:

Works perfectly & really really useful, kind of a magic !


PS : et en plus tu es français ! :slight_smile: Un petit bonjour de Massilia.

You’re welcome ! Salut du nord Isère

Hi guys,
Thanks for the post. I was looking for this kind of solution for a long time!

Is there an alternative for paprefs available? I am running Gnome and I’m hesitating a little bit to install all these KDE libraries as dependencies.



I’d like to help you, but I really don’t know about an other solution…
But, I’m working on Gnome environment too, and I’ve got no issues with KDE dependencies ans stuff.
System is still clean and perfectly OK.

Hope that helps ?



that sounds great… but I can’t get it working. Did you do anything on the volumio side (rpi3/volumio2 with hifberryDAQ+ connected to an amplifier in my case) to get the stream working? Must pulseaudio support be installed manually on the rpi?

More in detail:
I followed your steps to install pulseaudio-dlna on my pc (mint linux 17) successfully. If I run pulseaudio-dlna on my pc, my volumio appears as active in pavucontrol’s output section. But volumio does not seem to receive any stream (at least it is not playing any stream). In the terminal on my pc, pulseaudio-dlna tells me

09-18 16:23:57 pulseaudio_dlna.pulseaudio                     INFO     on_device_updated "/org/pulseaudio/core1/sink2"
09-18 16:23:58 pulseaudio_dlna.pulseaudio                     INFO     _async_handle_sink_update /org/pulseaudio/core1/sink2
09-18 16:23:58 pulseaudio_dlna.pulseaudio                     INFO     Instructing the device "volumio (DLNA)" to play ...
09-18 16:23:58 pulseaudio_dlna.streamserver                   INFO     Unregistered stream "/dWRuPSJ1dWlkOjZlYzI5Y2I3LTU2NzctNWFmNC0xYmNkLWI4MjdlYmY5MDVmOCIsdHlwZT0iYnJpZGdlIg%3D%3D/stream.mp3" (0x7f56e40e1f10) ...
09-18 16:24:00 pulseaudio_dlna.streamserver                   INFO     No more stream from device "volumio".
09-18 16:24:04 pulseaudio_dlna.plugins.upnp.renderer          INFO     Device state is playing. No need to send play command.
09-18 16:24:04 pulseaudio_dlna.pulseaudio                     INFO     The device "volumio (DLNA)" is playing.
09-18 16:24:04 pulseaudio_dlna.pulseaudio                     INFO     _async_handle_sink_update /org/pulseaudio/core1/sink2 finished!
09-18 16:24:04 pulseaudio_dlna.pulseaudio                     INFO     on_device_updated "/org/pulseaudio/core1/sink0"
09-18 16:24:04 pulseaudio_dlna.streamserver                   INFO     URL settings: /dWRuPSJ1dWlkOjZlYzI5Y2I3LTU2NzctNWFmNC0xYmNkLWI4MjdlYmY5MDVmOCIsdHlwZT0iYnJpZGdlIg%3D%3D/stream.mp3 (udn="uuid:6ec29cb7-5677-5af4-1bcd-b827ebf905f8",type="bridge")
09-18 16:24:04 pulseaudio_dlna.streamserver                   INFO     Registered stream "/dWRuPSJ1dWlkOjZlYzI5Y2I3LTU2NzctNWFmNC0xYmNkLWI4MjdlYmY5MDVmOCIsdHlwZT0iYnJpZGdlIg%3D%3D/stream.mp3" (0x7f56e4138650) ...
09-18 16:24:04 pulseaudio_dlna.streamserver                   INFO     Starting processes "parec --format=s16le -d volumio_dlna.monitor | lame -b 192 -r -"
09-18 16:24:04 pulseaudio_dlna.streamserver                   INFO     Processes of /dWRuPSJ1dWlkOjZlYzI5Y2I3LTU2NzctNWFmNC0xYmNkLWI4MjdlYmY5MDVmOCIsdHlwZT0iYnJpZGdlIg%3D%3D/stream.mp3 initialized ...
09-18 16:24:05 pulseaudio_dlna.pulseaudio                     INFO     _async_handle_sink_update /org/pulseaudio/core1/sink0
09-18 16:24:05 pulseaudio_dlna.pulseaudio                     INFO     _async_handle_sink_update /org/pulseaudio/core1/sink0 finished!

whenever I choose volumio as output. It then plays a song from my volumio library for some seconds (but not the stream from my pc) and then stops. On my pc I then get the message, that “the device disconnected”.

There’s no sink related entry in volumio’s web-gui. Do I need to activate or install anything on the rpi via ssh?

Any hint is highy appreciated :wink:

[edited the error message+description]

I wrote this thread with Volumio 1.55. I have to test it in Volumio2 as I’m not sure it works ( and you see that…). Nothing is ti be done in the pi side.
Butt take care in Pavucontrol, even without pulseaudio-dlna you should see a (unworking) device. Once pulseaudio-dlna is launched, a new device appears, this is this one to use.

Hi balbuze,
allright, that would be fantastic if you could try. In turn, I could also try with 1.55 as well, but I do not find it for download at anymore :confused:

Hejho, just solved the problem…
…well, not I actually; once more RTFM did the magic… Just tried some options listed at man pulseaudio-dlna and

--fake-http-content-length If set, the content-length of HTTP requests will be set to 100 GB. did the trick, i.e. with

pulseaudio-dlna --fake-http-content-length streaming from mint-xfce17 to volumio2@rpi3&hifiberryDAC+ works like a charm.
Thx balbuze for sharing this easy streaming approach, now can I enjoy Volumio even more :wink: