Strange Problem with Hifiberry DAC+


I’m using a Raspberry B+ in combination with the Hifiberry DAC+ device. I’m facing a few weird issues using Volumio:

  • the volume level of the analogue DAC+ output is only about 50%. Right after installation the output volume level was at 100% as it should be. I haven’t changed anything relevant within the WebApp. Even setting everything to default mode won’t fix the problem. The volume control shows 100% but the real output volume is definitely only about 50%.

  • the hardware mixer doesn’t work even though the Hifiberry DAC+ has a Sound Chip that supports hardware based volume control.

I’m only using Volumio as UPnP Renderer. Hope somebody can help - especially regarding the first issue.


This will sound improbable but works for me…

Select software mixer and reboot. Adjust volume to check it works then select Hardware mixer and reboot. Adjust volume to check that it works and you should now be able to get 100% output if desired.

As I prefer to adjust volume at the line level I take one further step and select Disable mixer and reboot. This gives 100% output.

Why this is needed I do not know…all I can say is I have the same problem as you describe at each new install of Volumio or its derivatives and this series of steps works each time.

Hi bobdbob,

thanks for the reply. Unfortunately that doesn’t help either. I also tried runeaudio like somebody else in this forum who faced the same issue. With runeaudio the volume is perfectly fine (even when changing settings). Unfortunately the UPnP function there has different issues. After 2-3 songs f.e. the song skipping causes a crash of the UPnP service - so you have to restart the system.

I want to stay with volumio but the volume issue with Hifiberry DAC+ is really a big issue. Especially because once you change a certain setting you can’t bring it back to the initial condition. Also due to this the sound is clipping/there is a overdrive at the maximum volume.

Well, I can only say it works for me, RPi B+ with HifiBerry DAC+, I have full working HW volume control with the dial.

What version of Volumio are you using ?

It worked for me using 1.5 and 1.55.

I only had to select the right DAC output and reboot.

But I remember having to change something command line in 1.5.


Maybe flash your SD card again ?


Hardware Volume control was finally working for me after finding & using the correct “simple mixer control”
“amixer” or “amixer scontents” is the command which lists the correct one, together with the settings.
see also