Static IP problem

We have version 3.423

We have configured a static IP on the raspberry pi2 and we have restarted the equipment but it continues to take IP by DHCP.

What can we do?

did you set the subnetmask ( most of the time it’s ),
next to your static ip ?
and switched dhcp off?

1 Like


1 Like

did this solve your problem?


and did you add your gateway? 192.168.XX.XX this is most of the time the ip of your router.
and don’t forget to save it.

on what version are you ?
is this a wired connection or wireless?

it should look like this

Sorry… I have the raspberry wired and I was setting the network configuration to the wifi interface…

I have put the IP configuration to the wired interface and it has worked the first time

it could be that your wifi password is wrong
and you could add dns and

here you can see both are working here right now.

and if you want me to check it please post: ip / subnetmask / gateway / ip of your router only local ip not outbound to find if there is a fault in that.
and you could try to add your password a few times till it shows on top.
it will take some time to set it.