SSH doesn't work after I've update to 2.129 (Raspberry Pi)

Today I’ve done the OTA upgrade to 2.129 version on my Raspberry Pi + HiFiberry DAC+ Volumio system, but, after that, I can’t access the system via SSH user volumio password volumio : every time the connection is closed.
Other linux scripts that I’ve done (that have always worked well until this update) now have some weird behaviour.
What can I do to fix these problems?

Thanks a lot, regards.

Did it definitely work before you updated? I’m assuming the update was not a fresh installation. It didn’t work for me before I updated, but I was unable to update so had to flash a new card with 2.129. SSH works fine.

Before the update it has always worked fine… I could connect via SSH without any problem.
After the OTA upgrade, nothing…

This is a known issue. To solve it you can go to system -> delete user data .

After this update this issue will not happen, sorry for the inconvenience

Ok, I’ve just done the OTA upgrade to v.2.141 and I’ve done the user data reset, loosing my settings… sigh…
After then, SSH is working well, but, very boring!, I’ve had to restore all the scripts to control the LCD (Sainsmart 20x4 I2C), the control buttons… :confused:


Is it still necessary to dump all user data in order to ssh into the latest (v2.175, 16 May 2017) update of Volumio 2 ?

No problems here after updating to v2.175 (ssh working fine), but you could always archive your ‘/data’ folder as a quick backup. See here & here.