Spotify plugin not loading playlists / playing files


New user to Volumio. Bought a new rpi3 and Allo Boss DAC which was delivered yesterday. Downloaded v2.310 from the website and loaded onto a micro-sd card.

Volumio setup was smooth and just worked fine. Real kudos to the devs. Made it really simple.

As part of playing with it I figured out how transfer over network some test flac files and they work great.

First observation is the Boss is a noticeable step up audio wise from my previous Chrome Audio setup. However growing annoyance is “popping” noise from the speakers when a new track start. I’ll put that in a different thread…

While playing around the web UI I installed the spotify plugin and loaded my credentials. It completed fine and I turned it on. From the logs it states “info: Spotify credentials grant success” so assume that means credentials are correct.

However from the browser menu, if I click on “My Playlists” nothing happens. In the logs it shows an error “info: Error: This socket has been ended by the other party”. I’ve uploaded log files to

The other menus work. However, as soon as I try to play a music track the same thing happens. The web UI doesn’t react and the log file shows the same error above.

What am I doing wrong? :confused:


Did you solve your problem if yes, How? because I have pretty much the same problem with spotify that you describe,
and kind of similar things happens when I try to play webradio for example i press top 500 favourite station “link” and nothing happens, same thing
in both volumio android app and apple app and webUI.