Spotify Plugin - authorize every restart


is this normal, that I have to authorize the Spotify Plugin Login after every restart of the raspberry pi?
So after every restart I have to go to the plugin setting and click “authorize” and accept this and then it works until i restart again.
Any ideas?


No, it’s not normal.

Make sure Volumio is updated.

If test mode or test mode plugins are enabled, disable these via yourvolumioaddress/dev

Uninstall Spotify plugin(s) and restart Volumio, then reinstall the latest Spotify plugin (currently v 4.0.3).

Thank you very much. I updated volumio and now it works!!

I am having the same issue, I have Volumios latest version… tried every Spotify version available and I have to authorize every time I restart… I have a Rasberry Pi 3b with a Dac pro…Ive restarted every time I delete Spotify and I continue to have this issue… help! lol

Me too. Thanks for bringing this up. I did the plugin uninstallation/reinstallation, and it is still hit or miss whether Spotify is authorized on startup.

Its nice to see Im not the only one… so frustrating… Ive tried everything… but still everytime I
shut it off I have to reauthorize… I have another setup that has Spotify 3.06 and it is flawless…
wish I could install that version.

On which hardware do you run Volumio?
If rPi4, is the datetime correct?

Does Volumio work with Spotify?

yes it does

It is a 3b witha DAC Pro…I can check the date and time… is that important?

I know with Qobuz, Tidal, myVolumio will not connect if the date is off.
Not sure if this is the case, but better safe then sorry.

I will definately give it a try…ty

Thanks @Wheaten The date is correct on my system (RPI/CM4) and it connects to Qobuz on every startup. This is only began after the latest update. I suppose I would need to try a clean installation next.

How do I disable Spotify from launching automatically at login?

How do I stop Spotify from launching on its own?