Spotify not working

I’ve entered my Spotify credentials in the settings and Spotify does not show up on the browse page. I’ve rebooted the player several times. What am I doing wrong?

Are you certain that you use a premium account?

What device do you use?

Have you checked the logging? What does it say?
I know of one login error that some people came across to solve it they had to reinstall.

Yes, I am certain it is a premium account.

Using a Raspberry Pi B+ with Volumio 1.5.

How do I check the logging? What needs to be reinstalled?

Please see this:

The consensus is that there was a typo in the spotify settings, correcting this didn’t work as it should, they reflashed and entered the info w/o typo’s and got it to work.

There is also debug / loginginformation in that thread.

Hi there- same issue. Was very careful entering Spotify credentials. Multiple reboots. spop service not running when doing pstree command. entering cat /etc/spopd.conf shows current and working user name and password for spotify. I am using HiFiBerry A/D converter.
root@volumio:~# cat /etc/spopd.conf
spotify_username = xxxxxx
spotify_password = xxxxxxxx
audio_output = sox
output_type = alsa
output_name = plughw:0

Spotify tab not available. I also have issue that if I leave the volumio player alone for a while, web interface unresponsive. Have to force power down and bring back up to regain access from time to time.

The same issue for my rpi & Volumio 1.51
config with correct login/pass (and active Premium account)
spopd is not running

errors in log:
[ERR ] Can’t load sox audio plugin: cannot open shared object file: No such file or directory

I’ve tried to reboot, off/on Spotify - still doesn’t work.
I also tried
apt-get install sox
but still no success :confused:

I’m not sure why, but I have to installed the volumio image serveral time until it works. I didn’t edit the spopd.conf file by hand. My Spotify configuration looks currently as following:

root@volumio:~# cat /etc/spopd.conf
spotify_username = MyUsername
spotify_password = password
audio_output = ao
output_name = hw:0

I using a Raspberry B+ and a Hifiberry DAC+ RCA

I’ve just recreate image with Volumio and… yes - it works.
Is it a solution?..hmmm… partially yes :wink:
I’ve used SqueezePlug for a few weeks but it often stopped work after a day or even after a few hours. But I was able to use Spotify in more convenient way…
Any way I’ll try to test Volumio - I’m using wifi TP-Link TL-WN725N (maybe only temporary ) and Audinst HUD-mx1 USB DAC.
For the time being it’s very well with radio - but I prefer Spotify recently…

I had the same problem. It turned out the /etc/spopd.conf had the wrong spotify credentials in it. This file is not updated when you change the credentials from the menu. It did work however when I changed the credentials in the conf file directly with nano. After that I could login normally to spotify and everything works fine!

I am also having the exact same problems, and being a complete computer noob, not to mention a Pi and Volumio one too, doing anything remotely technical is beyond me.

Does anyone know if this problem has been fixed, and the correct Spotify credentials put in, thus if I update my Volumio installation, it should rectify the matter?


Is there anyone alive in here??? :unamused:


I have concluded that Spotify will not be presented as an option if you are logged into Spotify on another device. Hope this helps.

Same problem here…finaly l bought a Denon receiver and it works flawlessly… :mrgreen:

I got Spotify working in Volumio 1.55 on a Raspberry Pi B, but the sound quality is atrocious when the output is set to my DAC. It plays music in like 3 second chunks like a robot. AirPlay from Spotify on my iPhone works fine. Spotify works fine in the Volumio web UI when the output is set to ALSA. Should I just wait for Volumio 2.0? :slight_smile:

You could turn of the high quality stream and see if that helps.

What kind of DAC do you use?

Turned off the high quality stream, still happens. DAC is built in to my amplifier, Topping VX1, which uses a NXP UDA1351TS DAC.

spot on :laughing:
This was really useful, wondered more than once why Spotify wouldn’t show.
It solved my problem.

I switched from my hifiberry dac to usb output (MyAMP) because the sound quality is much better. I was able to switch output device in playback options menu to MyAMP. Playback (and volume control) of files from NAS does work, however no sound using spotify plugin.

It seems setting mixer type to “software” in volume options section writes to /etc/spopd.conf :

output_type = alsa
output_name = hw:softvolume

However alsamixer showed hifiberry (broadcom mixer) was enabled.
I changed output_name in spopd.conf to corresponding cardnumber using aplay -l (in my case 5) to:

output_name = plughw:5

After reboot there is sound again when i play spotify music using the plugin. However I don’t have volume control.

Works fine for now, but there must be a way to set the alsa device another way with software volume control!?

I do have the same problem when i use spotify connect (Fornoth): works fine, but no volume control.

The previous action did brake the playback of my local files! The message “Error Failed to audio output”. Spotify connect still works.
Resetting playback options menu to audiojack and back to MyAMP with mixer type Nono and reboot did fix this issue.
However i am missing software volume control now in all occassions! And lost my still present hifiberry dac as output option!
Looks like volumio gets stuck with two output options? Might try to remove hifiberry…