spotify does not install

I encountered a really strange problem: The spotify plugin installation does not work at all.

Technical situation: Volumio 2.041 / Raspi B+ / HiFiBerry-Dac+ / Spotify premium account
HW working excellently with radio and older Volumio2 versions + spotify

I searched the plugIns and started the installation of spotify. It seemed to run however never reported “successful installation”.
The plugIn window appeared and I could open the settings and give user and password. Save did not seem to work

The switch could be set to ON, but the activate signal stayed red and spotify is not in the list for selection.

I had encountered some minor problems with my last spotify installation ( note: That was another SD card, so disregard any ugly remains).

Following my last troubleshooting I tried spopd -c /etc/spopd.conf
and got “spopd unknown cmd”

Further investigations showed that there is almost no occurrence of spotify or spop on this system and in the log file.
From my point of view I would try the installation again but I need help to remove the spotify entry in the GUI .
BTW the uninstall shell script is not much help in its present state…

Like warp2, I’m getting an error installing the Spotify plugin.

Volumio version: 2.041 released December 12th
Hardware: Raspberry Pi 2 Model B v1.1 with HiFiberry DAC+

Here’s the details when installing the plugin:

Downloading plugin at END DOWNLOAD: Creating folder on disk Unpacking plugin Checking for duplicate plugin Copying Plugin into location Installing dependencies The following error occurred when installing the plugin: Error

Problem is solved here, but I can’t report this for jlonge.

Your installation report ends right at the point where you would expect the interesting part of the story:

Nevertheless here is what helped me and maybe will help you too:

I looked up my old working spotify installation and the troubleshooting steps I did to get it working.

  1. My feeling is, that this installation stuck at some point. The reason might well be that I ran it on an iPhone which has some problems in running the GUI.

  2. I made another approach from my PC and tried to get spopd to respond. That was successful.

  3. I did:

[code]spopd -c /etc/spopd.conf

and got

	spopd: error while loading shared libraries: cannot open shared object file: No such file or directory[/code]

So there still is a problem in the dependencies, but this reaction is OK.

I did:

export LD_LIBRARY_PATH=/usr/local/lib/spopd 

This runs w/o any message and that should be it.

If not, try to save your username and PW again or check it in /etc/spopd.conf (both are listed unencrypted).

I hope it helps…

Spotify still does not run, There is no analogue audio signal while the GUI shows what’s playing and the playtime counts up. During my installation test I did not connect it to an audio amp, so this was kind of a surprise to me…