Spotify Connect

Hello dear Volumio team and music enthusiasts out there.
For me the “Volumio Spotify Connect 2”-plugin does not work anymore.

Both modes dont work. Every once in a while Volumio pops up in the device list of the Spotify Web-UI or the Spotify Android app, but only for a second. When you hit it fast enough you still cannot play any song to it.

I Reinstalled my entire sd-card for my raspberry pi 3. Regular Spotify works in Volumio.
I tried to read the log file (var/log/volumio.log) but that is only very little information (…demon startet…)

Is there any way to get more information?
I there a known issue with Spotify (like recent protocoll changes)?

1 Like

Same to me !!

Hi, there has been a fix pushed to the official repo, in the meantime, check out … otconnect2 for the current dev version.


PS: spotify-connect-t2811-350.html would be a better place to consolidate all issues!

Alright, didn’t know that page, sorry.
Anyways I used this:

wget mkdir ./volspotconnect2 miniunzip -d ./volspotconnect2 cd ./volspotconnect2 volumio plugin install
and it worked for me perfectly.
Thank you very much! :slight_smile:

Me too same thing as you

But I don’t know how to acces those command…
Newbie in the raspberry world.

How can I download the latest version like you have…because it doesn’t work for me

Any news from the official Spotify plugin updates?

Hi, First of all thank you very much for this fantastic plugin. I have been using it for months without the slightest problem.

But, since Spotify has “updated” it’s player to version 8.4.93, I think there is a bug which prevents song switching while connected to SC. If not connected to SC switching songs works. Unfortunately, it is not possible anymore to downgrade Spotify on the iOS devices (which could be a subject by itself :frowning:)

I have the latest version of Volumio (2.378) and the latest Spotify connect plugin (feb. 2019)

Any help would be greatly appreciated.

Hi, I can confirm this.
I’ve noticed this yesterday, but last week everything was working fine.

The problem:
You can use Spotify Connect: play, pause, next, prev buttons, but you cannot start playing another song (only for the first time) from any other list (playlist, album song list). It just starts the current song over again.
The same is on Windows and Android. I’ve tried to update Volumio to the latest version, also downloaded the latest Volumio image and set up Spotify Connect and got the same results.
There is no this issue using Chromecast Audio.

I haven’t tried updating the plugin manually to some development version.

Today I’ve tried moOde Player and the same issue was there. I’ve tried just doing anything, clicking anything. The interesting part is that you just need to click “Add to Queue” on any track and now you can play any song you like from any playlist or album.
The same issue appeared again and again it was resolved by adding any track to the queue.
Hope that will help someone.

I tried the “add to queue” workaround and it worked - allowing me to now switch songs from any playlist. Thanks! I’ve noticed there is an electric pop when it switches songs that had not been present before this glitch.

1 Like

Confirmed that it’s happening here, too. Looks like Spotify changed the API in their latest version?

I found the add-to-queue workaround and I can play things but it’s not ideal.

Can verify this as well with the plugin 0.74 that is in the repo on volumios pluginpage. Not able to change songs.

Also tried with the latest version 0.8.3 that is on github and installed that via ssh. That version does not work at all for me. Several problems with that one on a freshly installed rpi 3+. The plugin starts, i can set my settings. Changing startup volume from 30% to 95%, set my username and password. Everything seems fine. The try to switch to SC on the device but without getting any sound on the speaker (even after 10,15,60 sec)

Everytime i start spotify connect the volume is muted so i have to raise the volume but no sound comes out from the
speaker. Have tried several times with a freshly installed volumio but can not get this version to work at all.

Same happen here: cannot switch son. Only queque workaround.
Versio 0.7.4

Looks like this issue was resolved on librespot.
Just need to get the lib to the Volumio.

So what to do?
I’m Not able to fill anything into the Volumio library
Is there any chance to have an update plugin?

1 Like

Maybe this could be a temporary solution for you. Install the old version of the plugin. It works on my Pi3 with the latest version of volumio.
greetings … -466973509

Issue has been fixed, please install the latest (0.8.4) version of the plugin ( … otconnect2)

unfortunately this does not work for me.
I have the dev version 0.8.4 installed, change songs now works well only now I get no sound from raspberry pi and the volume in the plugin jumps every time back to 30% as soon as it is set to 100%.

Have you tried to save settings in the plugin?

me too

Disabled the plugin. In volumio playback, check if output is ok. Save. Reenable the plugin. In plugin settings save. Let me know.
What is your dac, volume mixer?