Special characters are replaced by question marks when playing internet radio

Hi experts,

when playing internet radio, special characters in title, artist etc. are replaced by question marks:

This is only the case when playing internet radio (appearantly no matter which station). When playing local or samba files, all special characters are displayed correctly.

When I play the same radio station via the browser on my devices, the special characters are also shown correctly. So I think it is a Volumio issue.

Any hints on this? I use Volumio 3.198 on a Raspberry Pi 3 with Hifiberry Dac+ Pro (but the version doesn’t seem to matter since I noticed this behaviour in earlier versions, too)

Best regards

No idea…but the letters which appear as question marks are, as we call it in Germany, “Umlaute” äöü. Maybe any part of the chain cannot show it correct.
The correct text in your picture above reads
Drei Stücke für Orchester
Regards, Achim

We should just stop with the German language :rofl:
(Wir sollten einfach mit der deutschen Sprache aufhören)

nah, prob. not. It seems your the only one posting in Turkish.

machet mer eifach uf schwyzerdütsch witer :yum:

I think there is a general issue with region/language/keyboard
(keyboard specific x86) settings.

I’ve seen this behavior before in the file- and folder names. Can’t recall if it was related to Volumio V2.xxx or a certain Linux distro. seems related to the charset/encoding. Names that were edited on a windows machine, using non std ASCII got renamed to some weird characters.
I am unable to reproduce, so it’s just an assumption.

Could be an older issue indeed, still hope this gets picked up as bug.
There is to be regional/keyboard setup to be done nevertheless, which is not a bug, just missing.

This behaviour is also shown with French characters :slight_smile: