Someone else must have (had) this problem. Help!

This is the same plea for help as in another post. I don’t yet have an answer.

I can happily use (wired) AirPlay with Volumio on my Pi/HiFiBerry Digi, but I cannot get Volumio to mount my music files which are stored on a hard disk attached directly to my iMac.

I can access the music files from another Mac on the same network using smb:// and I can also access them using the File Browser app on my iPad. For some reason I can’t mount the volume from Volumio.

This is very frustrating. I’m hoping this fresh post will bring me the answer I need.

Thanks in advance.


same here, but no solution yet…

How long have you been seeking a solution?

I hope this would help if you did not solve yet
when setting up the NAS from WEBUI, for some reason the NAS folder is not created
use ssh to login into the PI
cd /
cd mnt
if NAS is not there, then
mkdir NAS
after that try setting up through WEBUI, you should be ok
if you type ls NAS you should se the mount name as a folder
if you delete the mount from the WEBUI, this will probably happen again.

this solution was posted elsewhere. it happend to me just now and while looking for solution i remembered this

Thanks. I tried it, but with no success.

One of the issues I had was that the username for mounting the disk was the name of my Airport extreme and there were blanks in the name. I changed the name from “Living Room Base Station” to “LivingRoomBaseStation”. Mounting the disk worked afterwards.

It should be easier than this. I have a 20Tb NAS/server running 2008 R2 with a “Music” directory (as well as Movies Photos etc) and can access it with my cheapie dedicated media player, and tablet using Jellybean 4.1. Volumio cannot even gain access. It is not a permissions problem as the other two devices access it using the same user. Any ideas?

I have a tiny Synology USB Station NAS, and have it running a Samba share (the root of the drive) which is assigned the name “U”. I also used the Synology interface to define a userid and password. That being said (ie. the server side of the share is a bit of a black box to me), here is what I entered into the Volumio “Library” menu > “Nas mounts” to successfully access that share:

Source name: u2 (this causes the mounted drive to show up as /mnt/NAS/u2 on Volumio – technically known as the “mount point”; it can be anything you want)

fileshare protocol: SMB/CIFS

IP address: 192.168.x.x (change as appropriate; you might need to check your router to find out the ip number of the machine providing your share)

Remote directory: U (IMPORTANT to note thats the name of the SHARE I setup in the Synology NAS and its NOT the name of any actual directory or the above “source name”; took me a while to figure that one out)

Username: xxxx (change as appropriate)

Password: ***** (change as appropriate)

Click on “advanced options” to show them (YMMV with these):

Charset: UTF8
Rsize: 32678
Wsize: 32678
Mount flags: cache=strict,ro,noatime,dir_mode=0777,file_mode=0777

Then click [Save Mount]

The disk is mounted READONLY but for music playback that is fine by me. Its been rock solid once I got it right. It did take a bit of fussing about to get right so do persist. At the root of the share there is a directory named MUSIC which contains all my stuff. So the the Volumio “Browse” Tab I navigate to NAS > u2 > MUSIC and then through my folders to select what I want (my music is fairly well organised but not tagged properly; works for me).

Hope this helps someone else get their pesky smb mounts working in volumio.

cheers ess.