[Solved] Volumio not scanning /data/INTERNAL folder

Brand new user, have current version on Pi3 running Volumio’s own Pi Linux OS.

Got it working, using hotspot for the moment, connected to my windows machine, copied a few music test files to /data/INTERNAL.

Rebooted the Pi. Made sure permissions were 777, and ownerships of the INTERNAL folder and music folders were volumio/volumio.

I have tried settings → Sources → Scan many times, re-booted, etc. Volumio is not scanning the local folder on the SD card. There are .mp3 files in the folder.

Any tips please? It’s not permissions or ownerships.

Thank you.

Stupid question probably, but where are you looking to see your files appear? (things are not always obvious to a new user)

Not a stupid question. I appreciate the reply. I look under music library, albums, artists.

Are you able to ssh into your device?

How to enable and use ssh.

If so can you get directory listings of ‘/mnt’ , ‘/data/INTERNAL’, and one of the subdirectories in ‘/data/iNTERNAL’ please?

ls -la /mnt
ls -la /data/INTERNAL
ls -la /data/INTERNAL/mydirectory

Also, under ‘Sources’ in settings are there any tracks, and what happens when you select ‘rescan’?

Okay I think I solved it, I will change the topic to solved. I believe it was my fault. I’m a new user of Volumio, when I first installed, being comfortable with linux, I did a dist-upgrade rather than update through the settings menu. I believe that created a conflict with some files in the MPD package.

So I did a quick re-burn onto the SD card, booted, logged in and went through the first time wizard, it mounted and saw all the music files on my Samsung 32gb USB stick, scanned them properly and they are all in my library.

So never do an apt-get dist-upgrade

Yep, this a really big “no no.” Volumio has it’s own custom compiled packages (for specific things, not generally), and you will be sure to break it if you do ‘apt-get upgrade’ or ‘apt-get dist-upgrade.’

Glad you’re sorted, now you can listen to some music …

May I follow on this thread ?
I have the same problem, but no solution.
I mad a fresh installation …. Can see the internal (internal, NAS, USB) via SSD and wrote 2 files (for a test) on the internal NAS.
How ever, when I call the library …. A green line on top of the screen showstopper but no library is displayed. I have no access to the songs.
Nor does it see an external USB drive. (Kingston 400 GB - FAT 35 formatted)
What am I doing wrong ?