[SOLVED] Volumio.local stopped after first reboot

Hi all,
Rpi Zero connected via WLAN, Justboom Digi Zero DAC plugged onboard. After first boot to Volumio via browser and setting up WLAN and DAC options I could see Volumio connected to my home network. Also I can ping it from command line but I can not connect further to volumio.local via Firefox.
I can see Firefox trying to connect (there are messages Looking up volumio.local, followed by Performing a TLS handshake to volumio.local and The TLS handshake finished for volumio.local). After 5 seconds or so, Firefox gives up with “Secure Connection Failed
The connection to the server was reset while the page was loading.
The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.”
I also tried to SSH from putty to 192.168.0.xx port 22, which fails with Network error: connection refused message.
Tried connecting from Android phone to volumio.local to no avail.
On Rpi side I can login to console and see volumio communicating with home network.
Lastly, I have LED onboard DAC which was normally lit up when Rpi is powered. Now the LED is turned off… If i reboot the Rpi, LED would turn on for some seconds and later turns off, which is even more puzzling.
Volumio installed version is volumio-2.362-2018-02-12-pi

In reply to own post, it seems like my Windows laptop is acting weird. Tried connecting with Linux Mint PC via SSH and this part is working fine.
However, from Linux PC I can not connect through Firefox or Chrome, neither to 192.168.x.x. It seems like Rpi is actively refusing https, is it possible?

Do you mean https? If so, try http :wink:

Terrific, did not even think of this. On Linux machine and Android phone works both 192.168.x.x. On Windows laptop, IP address only. Oh well, I’m getting music finally. Thanks for support.

You would need to install ‘bonjour’ to get Windows to recognise volumio.local. This is an Apple protocol for recognising networked devices. Don’t be put off by the fact that it is called a “print services” package.

Bonjour is installed at Windows PC, to no avail. I’ve given up trying to fix that, as long as Android phone works as remote.