[Solved] Volumio as UPNP Server not working

Hi. I have 1.5 installed on a Pi B. I have enabled “UPNP\DLNA Indexing” and “DLNA Library Server” in the system setup. When using Android BubbleUPNP it shows volumio as a library but when you go into the library all the folders are empty.

I have a NAS share and also a USB stick with 10 odd audio tracks on it but nothing shows.

Any ideas on how to fix this problem?

1 Like

Does Volumio even act as a UPNP server or have I got that mixed up with it just being a client?


The NAS drive will need to be mounted to get the content in the Volumio “Server” side. Have you done this ? check out “Library” Menu tab if not.

However as you have a NAS drive it would make more sense to enable the DLNA Server or Apple Server on the NAS. What model of NAS drive do you have and is this functionality available ?

Then simply use Volumio as a “Client/Renderer” and Android/Bubble as your “Control Point”.

Some Advantages of this approach:-
-The NAS unit software is designed and packaged for file storage and indexing specifically.
-The files and the Index will be on the same unit (available to any device whenever NAS alone is powered up)
-Any future expansion to Multi Room will be straightforward, your server will already be established.

Good Luck


Sorry, Volumio cannot act as upnp server…

2014-11-20 DLNA Options.JPG

michelangelo, in that case could you please explain what the intended function is here for DLNA Library Server ?

DLNA server was disabled on the Raspberry Pi due to performance issues.

If you want to enable it, the instructions are here:


Can you confirm that that the DLNA Server button does not do anything ?

NWTStuff, I’m not Michelangelo, but you can confirm it for yourself. The MiniDLNA server has a small web server built in. Point your browser to
With DLNA Library Server turned off, you get nothing.
With DLNA Library Server turned on, you get a web page giving you the MiniDLNA status. You need to reboot Volumio if you changed DLNA Library Server, before it starts working.
Once you have edited the /etc/minidlna.conf file ( how-start-the-dlna-server-for-volumio-the-t2401.html ), the MiniDLNA status page will actually have the correct number of files in it.
Good Luck.