[Solved] volumio 1.4 can not install gcc

Hello folks!

I just upgraded my Pi to volumio1.4. I wanted to install wiringPi, but as I run the ./build script an error occures saying: “command gcc not found”. So I tried to install gcc with apt-get. It returend an error:

[code]volumio@volumio:~$ sudo apt-get install gcc
Reading package lists… Done
Building dependency tree
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
gcc : Depends: gcc-4.6 (>= 4.4.7-1~) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

I tried to resolve the problem with aptitude:

[code]volumio@volumio:~$ sudo aptitude install gcc
The following NEW packages will be installed:
cpp{a} cpp-4.6{a} gcc gcc-4.6{a} libgmp10{a} libgomp1{ab} libmpc2{a} libmpfr4{a}
0 packages upgraded, 8 newly installed, 0 to remove and 6 not upgraded.
Need to get 9,537 kB of archives. After unpacking 21.9 MB will be used.
The following packages have unmet dependencies:
libgomp1 : Depends: gcc-4.7-base (= 4.7.2-5+rpi1) but 4.7.3-11+rpi1 is installed.
open: 1; closed: 4; defer: 0; conflict: 0 .The following actions will resolve these dependencies:

 Keep the following packages at their current version:
  1. gcc [Not Installed]                                
  2. gcc-4.6 [Not Installed]                            
  3. libgomp1 [Not Installed]                           

Accept this solution? [Y/n/q/?] y
No packages will be installed, upgraded, or removed.
0 packages upgraded, 0 newly installed, 0 to remove and 6 not upgraded.
Need to get 0 B of archives. After unpacking 0 B will be used.
localepurge: Disk space freed in /usr/share/locale: 0 KiB
localepurge: Disk space freed in /usr/share/man: 0 KiB

Total disk space freed by localepurge: 0 KiB

I don’t know what to try else. Anyone else having this problem and probably solved it?


This has been said many times, think I need to stick it somewhere…

Use jessie repo

in /etc/apt/sources.list

change wheezy to jessie

apt-get update and voilà

In the current image it’s set to wheezy. Why not make it jessie?

Has anyone tried to do an “apt-get upgrade” after making the change to the jessie repo?

Wondering if Volumio will still work as expected…