Solved: Volume

I cannot modify the volume, is it normal?

Probably I should give more information, since nobody shared my problem.
I am using udoo with the jack and firefox.
I also tried to give the command direct to MPD, however, I received the following error
ACK [52@0] {setvol} problems setting volume
and this from the log
Feb 09 08:06 : mixer: Failed to set mixer for ‘Output’: failed to set ALSA volume: Invalid argument

I have solved changed the mixer type from Hardware to Software

That is strange: hardware volume should be able to change the volume. Have you tried switching to disabled, then back to hardware?

No, if I set Hardware the volume control does not work

Yes, Hardware volume control doesn’t work on all DACS. If setting Hardware doens’t work, that means your DAC cannot handle hardware volume…
I know it’s hard, but you have to face it.
How do you rate Udoo’s audio out? Did you tried it with headphones?

Sorry for the delay, I did not tried yet with the headphone.
I will try as soon as possible and I will let you know.

I have the same issue - raspberrypi with sabre 9023 dac via USB - it worked fine (hardware control) with raspyfi but not with volumio. When I try and change audio settings it generates a 404 error on the web GUI

I’m new on this forum.
First of all I want to thank developpers for their great job! I was looking for that for a long time.
I recevied my Dac … -8396.html this mornging, few soldering and go ! It works pretty well but I can’t set volume in hardware mode… I selecet the driver Hifiberry. So sad . As anayone an experience with that dac and Volumio (beta 1.3) working with hardware or is it simply impossible?