[Solved] Spotify interrupting sound

When i’m listening Spotify via Volumio, from time to time music stopped for a while.
This is not a problem with my bandwidth connection, because spotify on Mac or Iphone plays well.

Hi dziegma, sometimes this is caused by insufficient cache space. Check out this thread for some tips!

I’ve got the same issue with an old microSD card (from my e-reader). Very annoying.
I switched to a fast Transcend Class 10 MicroSDHC UHS-1 and that solved the problem.

After that I only heard a small hick-up at the moment a new song starts.
Switching ‘Gapless mp3 playback’ to ‘No’ largely solved that issue.
Plays wonderful now!

Gear: Raspberry Pi B+, Hifiberry digi+ (transformer), Beresford Caiman DAC, Rotel power amp, Monitor Audio RX6.

Thanks Rook, I will buy a fast SD card and will test this today.

It seems that new high speed card (SanDisk UHS-I) has solved this problem.
Thanks for advice.

Changing the SD card solved it for me as well. Thank you!

I solved this in another way, by moving the cache onto the Ramdisk.

I added the following two entries to /etc/spopd.conf:

cache_path = /run/shm
cache_size = 128

asgeirn’s approach is good, but I have found (and others with me) that the cache_path setting is ignored by the client. You can instead create a symlink from /.cache to /run/shm
Also, 20MB cache seems to be enough for me.

asgeirn’s approach does work, if the cache_path is put under [spop] in the config file. Not doing so was the cause of my failure.
However the cache_size setting seems to be ignored by spop.