[Solved] Some webradios ok, some not

After my fresh install, some web radios are OK, some are not and nothing happens when I click on the UI.

Investigating the pb, this is not a webUI pb, but a mpd pb. Indeed, when I ssh to volumio, and sends the link of the webradio, using mpc, the pb still occurs.

For instance, when I want to play this radio mp3.live.tv-radio.com/fip/all/fiphautdebit.mp3, it plays for two seconds a dirty sound, then stops.

With the same dac and an other machine ( my laptop asus eepc, lubuntu), mpd plays fine.

Some ideas ?
Thanks a lot, Laurent

PS: config, rasp B+, weilang dac5,


I “had” the same problems with some Radiostreams


At the moment I am stil using MusicBox (at my work) instead of Volumio and that works fine…
Maybe an update of mpd will solve this!

Kind regards


Tried today with an other dac. Same problem.
The rest of my configuration is very generic: raspB+, volumio 1.5

Thus the problem could impact many people.

Confirmation that this is a mpd issue : streams play OK with mpd 0.19.3 and 0.18.6 but not with the mpd 0.19.1 provided by volumio 1.5.

Source of this claim here: bugs.debian.org/cgi-bin/bugrepo … bug=769436


Did you try to add and play the radio the following way?

Go to

Search for the radio you want and download the m3u file (right click on radio name --> save link as; NOTE: It does not work with safari for me). Rename it as convenient and drop it in the WEBRADIO folder of volumio.
In the WebUI, update the WEBRADIO folder, and you will see it listed there.

Alternately, drop the m3u file in the playlists folder of volumio.
It will appear in the browse tab of the WebUI, outside of the WEBARDIO folder (you may have to update the mpd DB before it appears)

If you drop the m3u file in the playlists folder, it will also appear as “saved playlist” in Mpod (don t know about other clients); No need to have access to WebUI to play webradios!
Also, if you use IR remote, you can easily tell mpd to load and play the webradio (or any other saved playlist) when pressing a button on the remote. No need to look at your phone/tablet!

Works for me like a charm with cubox-i2ultra and volumio 1.5.
Just give it a try!

Confirmation that this is a mpd problem. After compilation of a new mpd, I can listen to all the radios.

I have the same problem (with the same french radio group, by the way :slight_smile:
If I understand, the problem was solved by compiling/upgrading mpd in Volumio ?
Is it difficult to do this upgrade (on a BeagleBone Black) ? I’m quite a newbie in Linux :frowning:


I had the same problem but instead of recompiling a new MPD version I changed the URL of the streams. I will give you the informations tonight.

Hi Stephane,
Thanks a lot, that would be a lot simpler!
I already tried a few variations (with a .m3u file, or various .pls ones), but I didn’t find the proper syntax…


Here are the URL of the streams from France Inter and France Info: … tdebit.mp3

I have a playlist with all the radios I’m listening to, a simple M3U file with each URL on a line.

Thanks a lot!
I’m not at home till Monday, I’ll implement it as soon as I’ll go back.

This works! Once again, thanks a lot Stephane.