[Solved] SMB/CIFS failure - Mac OS X 10.9 - Airport Extreme

After following Lag-na’s sticky I’ve gotten a little further.

Doing steps 1 through 7 got me:

Last system mount error
mount: wrong fs type, bad option, bad superblock on //, missing codepage or helper program, or other error (for several filesystems (e.g. nfs, cifs) you might need a /sbin/mount. helper program) In some cases useful info is found in syslog - try dmesg | tail or so

After changing the flag option to what Lag-na suggested I got:

Last system mount error
mount: cannot mount block device // read-only

When I set the account up i selected read and right. So I’m not sure where this message is coming from. Please see attached images for anything that I might have missed.

The directory name should be just the name found when connecting to the ip? Or should it be the path?

Untitled.tiff (36 KB)

Untitled 2.tiff (164 KB)

Untitled 3.tiff (77.9 KB)

Well if you cannot mount it read-only (strange) try removing the “ro” from my advanced parameters.

Have you tried executing

 dmesg | tail

immediately after you got the error? that gives additional useful info.

I’ll try that when I get off work. I haven’t been able to access via ssh. username and password is volumio, correct?

The same you used previously.

I mean the user name to access ssh.

Do I have to have the airport setup with accounts (username and password)? Would much rather just require the device password.

removing ro gives me:

Last system mount error
mount: block device // is write-protected, mounting read-only mount: cannot mount block device // read-only

root@volumio:~# dmesg | tail
[ 35.135943] Installing knfsd (copyright © 1996 okir@monad.swb.de).
[ 64.032268] CIFS VFS: bad security option: ntim
[ 64.935933] bcm2835-cpufreq: switching to governor performance
[ 64.944746] bcm2835-cpufreq: switching to governor performance
[ 205.795078] Status code returned 0xc000006d NT_STATUS_LOGON_FAILURE
[ 205.804004] CIFS VFS: Send error in SessSetup = -13
[ 205.811696] CIFS VFS: cifs_mount failed w/return code = -13
[ 302.685207] EXT4-fs (mmcblk0p3): error count: 3
[ 302.691992] EXT4-fs (mmcblk0p3): initial error at 1396987247: mb_free_blocks:1426: block 309248
[ 302.705550] EXT4-fs (mmcblk0p3): last error at 1396987322: ext4_remount:4680

“sec=” requires either “ntlm”, or “ntlmv2”, or, for OS X and similar, “ntlmssp”
“ntim” is wrong

Many thanks Lag-na. That did the trick! I used some other work around too that got it to mount with ssh but disappeared after a day or so. So I tried your suggestion on ntlmssp for OS X and it has worked. I want to try from a clean install before I add this to the sticky.

mkdir /mnt/NAS/myNas
chmod -R 777 /mnt/NAS/myNas

along with

sudo mount.cifs // /mnt/NAS —verbose -o user=Volumio,password=xxxxxx,rw,iocharset=utf8,sec=ntlm

From a clean install can you try it simply from the UI without doing any ssh stuff first? It’s worked for me and hopefully will for you too.

Finally got it to mount with the web UI.

in mount flags i used:


The code below didn’t work. The web UI would just hang.


Just to be clear…
I set the airport extreme up with an account.
The Airport’s attached hard drive in my case is named AirportNAS which is what I used for the remote directory.

Thanks for all the help Lag-na!