[Solved] Samsung S7 drops Volumio Wifi interface

Hi guys,

I know the topic’s title sounds a little crazy, but there it goes: as soon as I connect the Samsung S7 Edge phone i own to Volumio, the Wifi interface of Volumio drops.

More precisely, the first time I try to connect, the Volumio app doesn’t find any device. If I hit the “search” button, the Wifi interface of my Volumio device drops instantaneously.

I’ve tried either with the official Android app or by browsing 192.168.0.X/playback with the same result. As soon as I try with the Samsung phone, the Wifi interface drops.

No problem with another Android phone, tablet or by using a computer.

From my laptop, I can still ssh the Volumio device by wiring it with a cable (I can also use the web interface just fine with the cable). But the wlan0 stays down no matter what I do from there.

sudo ip link set wlan0 up

Last test I did was to enable the Wifi interface from the Volumio web interface. An error message jumped right away claiming that systemctl wasn’t able to start networking.service.

Any help is much appreciated, and kudos for this wonderful piece of software !

  • Board: Raspberry Pi 3
  • DAC: HiFiBerry DAC+ Pro
  • Wifi security type: WPA[/list]


Small update as I realized I didn’t specify the Volumio version: 2.246

Also, tried with Hotspot OFF with no luck, and with no USB attached whatsoever (just playing the files over Wifi from the NAS).


Hi guys,

I came across this post, so I did try to change the Wifi channel I was using.

Still no luck.

This is frustrating as I cannot use my phone as remote at all…

Thanks for your help.

Well, I finally got this working.

See here for anyone interested, and thanks to the hifiberry guys.