[SOLVED] Raspberry Pi Zero W - no hotspot on boot

Hi there,

I’m in the process of a new device build with Volumio at the heart of it but space is more restricted than usual so I’m using a Raspberry Pi Zero W. I’ve imaged the card with a freshly minted 2.348, however on completion of boot, there is no “Volumio” SSID available to connect to.

I see some history here showing that that a device tree file needs to be added. However that was back in May for 2.118 and the post says it was fixed in 2.129.

I don’t have a way of looking at the console on this device (HDMI and USB OTG adapters are on order but delayed due to Hogmanay/NY shutdowns) but I wondered if this was a known issue with a resolution I can apply before they arrive.


I’m at roughly the same point as you but had no problem finding the Volumio hotspot. Needed to do a spot of research to find the network security key (volumio2) for it as I’m still finding my way around the documentation but it worked for me with no need to set up a file tree.

I also have tried a fresh install recently on a Pi Zero W and the hotspot comes up for me. It takes a while (maybe 10 minutes) but it does show up. My issue is that I can run Volumio very nicely for the first few hours, then the whole system completely crashes. I’ve tried different SD cards and using minimal settings, but it still won’t stay up longer than 1 day. I’m only adding this because in my experience the Pi Zero W is not a very capable platform.

OK, my mini-HDMI adapter and USB OTG adapters arrived so now I can see the problem in the log on screen - the volume resize was not happening on reboot because the e2fs volume was dirty, and the RPi ended up in an Emergency Shell.

I’ve had this problem before imaging in Xubuntu as the eject/unmount process appears to leave some connection behind so I reimaged in Windows 10 and, voila, everything now proceeds as expected - hotspot appears, can reassociate with my home network, all good. Who woulda thunk that Windows worked better for imaging a Linux SD card than Linux but hey :wink:

There’s no sound out of my i2c DAC, but that’s a problem that warrants separate investigation … :slight_smile: