[SOLVED] problem with volume control on pi and pifi dac+

Hello everyone,

I am using a raspi2 with a pifi dac+ (vullers tech). This one seems to be a china-clone of hifiberry+ but when I bought it a few years ago hifiberries were sold out in germany :frowning:
On volumio I use the hifiberry+ setting, it’s the only one that works with my dac.

There is a problem with volume control:
Hardware doesn’t work from the gui though it seems that the setting for the initial volume (i chose 50%) is recognized and set accordingly.
When I try to change to software-control, volumio crashes.

My version is: 2.201

Controlling Volume from remote would be nice, because my historic luxman-amp doesn’t have a remote …

By the way: there seems to be a small glitch in the way the dac-type setting from the gui is transferred into the config.txt

  • when I tried various combinations of dac-settings, the gui produced additional lines with device-tree-settings.
    And because the last one obviously rules, my changed settings were ignored.
    After editing config.txt and removing all unwanted occurences of those lines, my volumio finally produced a sound.
    Hope this helps


  1. Have you set Mixer Type: Hardware and Mixer Control Name: Digital ?
  2. Have you checked is it possible to control volume via aplay in ssh terminal?
1 Like

Hi marceli,

thank you very much:

number 1 did the trick for me, i.e. setting the control name to digital.

best regards


1 Like

I have the same setup, and the same problem. However, the solution does not work for me :mrgreen:

I have the option to set Mixer Type to Software (was None before). However, by doing so, I don’t get any sound output anymore.
Mixer Control Name I cannot set. The only option I have is none.

Anyone knows what’s wrong here?

Here’s a log file - if anyone can see anything suspicious in there: logs.volumio.org/volumio/fGyh91p.html

Have you got I2S set to ON and have you choose HiFi DAC+ PRO as a device?

Yes, I2S is set to on. However, I just realized I use a PiFiBerry Digi, which is similar to the HiFiBerry Digi, which I chose as the device, and not the HiFiBerry DAC.
Audio playback works fine, it’s just the volume control I couldn’t get to work so far…

I tried HiFiBerry Digi, as well as HiFiBerry Digi+ Pro, however I can not set mixer type to software.
When I do and hit save, my rasbpi seems to not respond and I cannot access volumio.local anymore. So I have to cut the power and restart. After that, mixer type is set back to none again :confused:

What can I do?

  1. Try to set Volume as Digital, not Software.
  2. Try to login via ssh and run alsamixer.

Hi marceli,

thank you for your reply.
Unfortunately I can not set Volume to Digital, the only option I have is Software (see attachment), for which my rasbpi still crashes…

I have a similar Problem.
The only Setting that works is Hifiberry Dac Plus, and the Mixer Type set to digital.
Volume Control basically works, but using the UP and DOWN Volume Controls I can only set the Volume to a max. of 31.
Tipping into the Volume Circle I can choose any Volume up to 100, but not through the UP & DOWN Controls.
Therefore to fine gain control the Setting is really hard right now.

Thank you, this worked for me as well :slight_smile: