[Solved] Problem making Hifiberry DAC work


I just purchased a Hifiberry DAC, and I am trying to make it work with Volumio, but I can’t get any sound out.

I have first tried to activate the I2S driver via the Volumio UI, rebooted, and seen that the audio output was configured as the Hifiberry (can’t remember the exact name). But no sound.

Then according to this thread hifiberry.com/guides/hifiber … iguration/). But still no sound.

Can anyone help me with this please?

My environment:
RPi model B
Volumio 1.4
Hifiberry DAC

Maybe a solder problem?
I had the same problem.
But I didn’t solder the p5 correctly.

Thanks for your answer mbliek!
But I bought the RCA version, not the DIY one.
So there is nothing to solder. So maybe a HW defect.

Are there any logs that can help?

You did have to solder the p5 header on de raspberry.

hifiberry.com/solder-the-p5- … -model-ab/

You did that?
To check if it’s reconised to login via ssh and run the command aplay -l and you should get something like this:

**** List of PLAYBACK Hardware Devices ****
card 0: sndrpihifiberry [snd_rpi_hifiberry_dac], device 0: HifiBerry DAC HiFi pcm5102a-hifi-0 []
Subdevices: 1/1
Subdevice #0: subdevice #0

Well that’s what I just noticed while browsing the hifiberry site more deeply. I didn’t realize I needed to solder a connector.
The 8pin connector is not included in the package, I’ll need to get one then.

I will sort this out, and try to make it work.

Thanks for your help

You should have got it with the hifiberry when you buy is new.

Yes, the guys from Hifiberry just confirmed that it should have been included in the package (they are quite reactive by the way).

Once I get it, and solder it, I just want to make sure how to install it software-wise.
Should I do it from Volumio GUI (first test I described earlier)?
Or should I do it “manually”? Cause the thread I have referred to seems a bit old, and I am not sure it’s still valid.

You can just do it from volumio

the easy way: solder it -> plug it ontop of your raspi -> boot it -> select the i2s -> reboot and enjoy the sound^^