[Solved] Problem Creating a mount to Netgear NAS

I had a similar problem with Raspyfi and gave up. With Volumio I hope I may be able to solve the problem because it gives some error messages unlike Raspyfi.

Symptoms - I’m connected and set-up OK working over WiFi. I can play Webradio fine, but cannot get the NAS to mount.

The first few times I think I just had the path wrong with too many slashes etc so it could not find a mount of that name. Now I think I have the correct path because is now says “mount: Operation not supported”. I’m using Windows 7 laptop and trying to mount my NAS which has a fixed IP on the LAN. The NAS is definitely aliove on the network - I can ping it and can navigate to it and open files (via windows 7 PC)

I’m using SMB/CIFS, but have also tried NFS with no success.

Can anyone advise? Please go gently as I am a complete novice with Ubuntu, although I’m very familiar with the concept of MS-DOS command prompt window. I have Putty installed and can run commands by cutting and pasting, but have zero understanding of what the commands actually mean!

Hi all.
I have a similar problem. I just can’t make it connect to the Netgear NAS. Only difference is, that my NAS isn’t on a fixed IP adress, but i still know the right adress.
Have tried all thinkable permutations of mounts and adresses, - and have given up.

I hope the community can help.

Thanks in advance
Merry Christmas from

use mount flags: sec=ntlm

I have a sparc ReadyNAS Duo and had the exact same problem. Adding that mount flag worked perfectly!

Happy to say, this also worked for me. Thanks for the info!