[SOLVED] No more LAN/Wifi since 2.834 update on x64 old computer

Volumio Information

Volumio Version: 2.834
Hardware: PackardBell onetwo LD5102FR


All is in title. Everything work fine whit wifi before update (it was version 2.799) and after update and reboot no more network (wifi or lan). When i try to activate wifi in settings panel, change is not saved.

Known problem in last update or any ideas of how to detect the reason ?


Very strange!!!
Could you send a log and paste the link here?


Yep, but how can i access to the /dev/ page since volumio is not connected to local network ? Can i get that from the volumio pc ?

Mmmm you’re right.
Can you connect an HDMI monitor? Did you set up some static IP?

I have a monitor on it.
I tried a static ip but no luck either. My change for the static config. is saved and the switch is “on”, but the on/off for “wireless networking” always go back to off.
I tried looking for logs throught command line but it’s out of my linux competences.

I find some error running “journalctl -f” : I click save after switch wifi on and got this :

First error block with :
ieee80211 phy0: rt2800_wait_wpdm_ready: Error - WPDMA TX/RW busy [0x00000068]
ieee80211 phy0: rt2800_wait_wpdm_ready: Error - WPDMA TX/RW busy [0x00000068]
ieee80211 phy0: rt2800pci_set_device_state: Error - Device failed to enter state 4 (-5)
(repeated twice)

and lower, dhcpd error : Not configured to listen on any interfaces!
and systemd : dhcpd.service : control process exited, code=exited status=1

Is it useful ?

Ok, don’t try to understand, i shutdown pc and start again and everything is fine… I’ve tried to reboot several times, but not shutdown. Don’t know if it make difference.
No matters, it works. Sorry for disturbance…

Great to hear! I think that your net card went into some freeze mode. Glad to hear it’s solved