*SOLVED* NAS via Airport Extreme

Dear all,
I am quiet new to volumio and quiet new to mac, which seems not to be a great combination if one decides to mount a NAS.

The setup:
The Airport extreme is attached in bridge mode to the router.
To the Airport two harddisks are connected with a hub.
We have two partitions on the relevant disk, one for timemachine backups, one for music.
The IP of the Airport is, the partition is called “SILVER” and the name of the directory is “NASMusic”.
Currently the security setting for the harddrive is “Base Station Password”.

No matter what I tried so far, volumio’s standard reply was: “mount.nfs: Connection timed out”

I am pretty sure, that I am doing something incredibly stupid, but I am struggeling to find a starting point for my troubleshooting.

Can anyone help?

Many thanks,


I suspect you’re doing nothing wrong. I’ve been have a similar problem connecting to a HDD attached to my iMac. I’ve also tried Rune and have the same problem with it, but the Rune developers have told me to expect a solution very soon.

As I said before, I am a kind of a newbie, but I am able to copy&paste code and to access my Volumio via ssh. Is there any difference in mounting permanently a NAS in Volumio in comparison to a Pi running on raspbian?
There should be some nice how-to-do-it manuals for raspbian out there.

Let me know when you’ve found it. I’ve been searching for weeks.

Try this thread. Ek gebruik nie Airport Extreme, maar wel 'n NAS. Sit die naam vir jou NAS waar die voorstelle /NAS vra. Geluk.


Dear Pete, thanks a million.
I managed to mount the disk.
To get on your volumio:

sudo ssh <ip of your airport>

If necessary:

sudo apt-get update


sudo apt-get install cifs-utils

root@volumio:~# mkdir /mnt/NAS/NAS root@volumio:~# chmod -R 7777 /mnt/NAS/NAS

sudo mount.cifs //<ip of your airport>/<path to your music directory> /mnt/NAS —verbose -o user=<name of the airport>,password=<airport password>,rw,iocharset=utf8,sec=ntlm

Unfortunately this works just till I reboot. I think my entry in the fstab is wrong.
To get there:

sudo nano /etc/fstab

Anyone any idea?
The line I added is:

// /mnt/NAS cifs user=********,password=********,rw,iocharset=utf8,sec=ntlm 0 0

Doing some Google research I stumbled upon this sollution:
Would it propably work with volumio as well?

Hi Johannes
It might be an idea to use cron to remount when you boot. You could also set up cron to restart at some (quiet) time of the day, to help prevent losing your mount. Check out LeChucks posts in this thread, how-mount-nas-t821.html
I found this to be very helpful, and it solved my unmount issues.
You might find the attached useful - I have saved some setting info to make the set up process easier for me. Where settings are shown with X is where you need to insert your info (and perhaps full url if yours is different).

Please note, all this info was gleaned for other, cleverer people than me on this forum - I have just distilled what has been useful for me. :slight_smile:

Volumio Settings

sudo apt-get update
sudo apt-get install cifs-utils
To mount NAS – original script:
sudo mount.cifs // /mnt/NAS —verbose -o user=USERNAME,password=PASSWORD,rw,iocharset=utf8,sec=ntlm

  • My script:
    sudo mount.cifs //192.168.X.X/XXShareXX/XXFolderXX /mnt/NAS —verbose -o user=guest,rw,iocharset=utf8,sec=ntlm
    Create mount point (as root): - original script
    mkdir /mnt/NAS
    mkdir /mnt/NAS/NAS
    chmod -R 7777 /mnt/NAS/NAS

  • My script:
    mkdir /mnt/NAS
    mkdir /mnt/NAS/XXShareXX
    chmod -R 7777 /mnt/NAS/XXShareXX

Keep mount mounted: sudo nano /var/www/command/orion_optimize.sh
Then look for the following lines (be careful, quite a few similar looking lines, make sure you get the right one!)…:
if [ “$2” == “startup” ]; then

kill useless system processes

… then find the following in that block of code: killall -9 cron
… add a “#” to comment (disable) the killall command so it looks like follows: #killall -9 cron

  • Save and exit nano.

Set up crontab: sudo crontab –e

Actually the solution was even simpler. I just had a typo in my fstab. The IP of my Volumio is and not :unamused:
It finally works!

Thanks to all who helped me!

I seem to be getting somewhere with this too, bur when I enter ‘sudo crontab -e’, I get ‘-e: No such file or directory’.

Any advice?

My next question:

I have my Music folder mounted, but I can’t see any Music files. What’s up?

Maybe try

sudo apt-get update
sudo apt-get install cron


I don’t think I need it after all. It seems to remount after a reboot, but I’ve not yet seen music files when I browse. Any ideas?

This works for me :slight_smile:


Can someone please help? I tried doing this - but for some reason I cannot get my music files from my airport extreme to be recognised on my Volumio player