[SOLVED] Mount USB drive on VDSL2 Technicolor modem

Well I have a router VDSL Technicolor AG plus VDNT-S, that can works also as media server.
This is the modem supplied in Italy by Telecom Italia, with the VDSL2 connection.
So, if anyone has already mount this media server, please let me know how it must be configured, otherwise solving this issue probably will solve a problem for so many people.

Use as media server the USB port of this router may be useful, as first because it’s always turned on and there’s no other NAS to buy and to supply. My router is also powered with an UPS, so the HDD connected doesn’t risk to be damaged with an electrical power down.

I can easy read a pen drive connected on the USB port of the router, as network drive, and I can see it with some other DLNA devices as well.

I’m using raspberry PI 2, dac-pcm5102-i2s, Volumio 1.55, wire connection between raspberry and the router.
When I try to SAVE, after added a new share in menu --> library, I can’t see a new NAS in the browse panel, and I have no more access to any menu option. So I have to take out the power.
This router is declared to support SMB protocol.

IP address: (Even without fixed IP, I always found raspberry on this address).
Remote directory: I tried “music”, “/music”, “music/” … ?
This is what appear in the router menu:

The right share name write is: “/music”

User and password: are user&password necessary, even if raspberry is still connected and communicating with the router that’s also the media server? When I get in the Technicolor router, it ask me only the password, but I discovered that the user id “admin” because it is the only one user that let me open the pen drive as network drive.

Finally, tried also to write “ro,noatime,sec=ntlmv2” in the Mount flags on the advanced options, but it doesn’t seem to change anything.

May thanks in advance to everybody and greetings from Venezia!

P.S. Please be patient with my broken English …

I discovered that my technicolor router, even if on address, locate the connected usb device at address (I can find the usb pen drive at both those IP addresses).

The name of the share is Disk_b1 that identify the entire USB device

Inside Disk_b1 I can find the folder music

So I’m now attempting with:
Name: router
IP address:
Name of the share: Disk_b1
User: admin
Password: ********

Mount flags: ro,noatime,sec=ntlmv2

But it still doesn’t work, and no SMB/CIFS share appears inside NAS:

For all the Italian Volumio user, with VDSL2 internet connection (telecomitalia), that would mount a flash drive on the USB port of the Technicolor router, this is the solution:

As first, a strange thing, even if the router is on the usb port is mapped on

Source name: as you want
fileshare protocol: SMB/CIFS
IP address: (or Disk_b1 if used USB2)
Remote directory: – keep empty –
Username: admin
Password: ********

advanced option

Mount flags: ro,sec=ntlmv2

Don’t add noatime because the mounting fail

Working manual mount :
sudo mount -t cifs // -o user=admin,password=******,ro,sec=ntlmv2 /mnt/NAS/router