[SOLVED] MINI86 Update Problem - No longer working

Was listening to my MINI86 this evening. Checked the system tab which advised there was an update. Installed first update (think it was 225) which indicated that it was an intermediate update. Installation went fine. Installed the next update (think it was 228) and now there’s no functionality. No access at volumio.local and no hotspot visible on my list of available networks. Any assistance will be appreciated.

Hi, which plugins did you have installed?
I suggest you to do a factory reset: you must do it with the USB disk method, since you can’t access the UI.
To do it:

  • Use a fat32 USB drive
  • Place a file called factory_reset on it
  • Turn off the Mini86
  • Insert the USB disk and turn it on
  • Wait 10 minutes and the mini86 will defalt to factory settings

Try to update again, let me know

Hi. I had the Spotify plugin installed. Where do I locate the factory_reset file?

There you go:
repo.volumio.org/Volumio2/update … tory_reset

That file location is empty.
file location image.PNG

Just download this file (factory_reset) and place it on the USB drive

Sorry if I’m missing something. Your last message seems to point to a link or attachment but I don’t see one.

1- Download the file I linked above
2- Place the file on a FAT32 formatted USB Stick
3- Connect the USB stick to Mini86
4- Turn on the Mini86
5- Wait 10 minutes, it will go to factory settings
6- Retry to update

Let me know if you need more help

There is a misunderstanding. There is no file at the link at the link you indicate above.

Ah. Now I get it. Even though the file has zero bites of information in it it simply acts as a command to the device to do a factory reset.

OK. I copied the file onto a USB stick. Here’s a snip showing the contents of the stick. USB stick contents.PNG

The USB stick is FAT formatted. Here’s a snip showing the properties of the stick. USB Drive E properties.PNG

I plugged in the USB stick.

I turned on the MINI86. The led on the USB stick began glowing, indicating that it was properly connected to the MINI86.

I waited ten minutes.

No hotspot and nothing at volumio.local.

I tried a second time. Turned off the MINI86. Inserted USB stick. Turned on the MINI86. Waited for 20 minutes. Again, no hotspot and nothing at volumio.local.

Ok, I will replicate your situation and provide help on how to fix it.
From which version did you update?
Can you take a screenshot of what you see on the display (via HDMI connection?)

I can’t take a screenshot. The screen shows the following:

SYSLINUX 6.03 EDD 20150020

No DEFAULT or UI configuration directive found!
boot: __

I don’t know what the prior system version was but guess it was 220. In any case, it was the version my device shipped with.

I’ve successfully identified where the problem lies, please bear with us I will get back with a solution hopefully soon

Ok, found the problem and the solution to it.
Don’t worry, it’s very easy.

1- Connect the Mini86 to a display and to a USB keyboard
2- Turn it on, and immediately start pressing ESC key until you see a blueish screen (BIOS)
3- With the left arrow key, navigate to boot section, then with down key navigate to the “BOOT OPTION #1” item
4- Press enter, and select the entry that starts with UEFI
5- Press enter again, and navigate to “Save & exit” , and press enter and click yes

Basically, what you did, is enable Volumio boot in UEFI mode, which is unaffected by the bug that prevents the system to start. I’ve tested this procedure and it works, please let me know

Thanks! Glad I have a USB keyboard. Changing the boot priority as indicated in your instructions got it working. I note that it’s running version 2.282 without any updating actions on my part. I appreciate your excellent support.

I’ve similar problem after following instuction change boot option#1 to UEFI. what it is shown on screen :

                              GNU GRUB version 2.02 beta2-22+debBu1


It become command line which I can’t go any further. please help.

Same problem here.
I’ll create another post.

@sonn which hardware do you have? From which version did you update to?

@michelangelo I bought Mini86 from this web a few month ago and software update version must be the latest one maybe 2.285