[Solved] Lost "System" page after updating Web-UI via git

Hi all -

I have a fairly stock install of 1.4 on the Cubox platform, on which I’ve updated the Web UI via “git pull” inside of the /var/www directory as instructed elsewhere on this forum. I’ve done this twice - once about a week ago, and once this morning when I got all excited about some Spotify related updates that got merged recently.

Everything has mostly worked well - I’ve been able to run the updates python script via the web browser with each pull, which has seemed to work as expected.

However, since the first update via git, the “System” page returns a blank, empty response. The latest update hasn’t resolved this.

I don’t see anything related to this in the nginx error logs.

Is this a known issue due to the “alpha” nature of the Web-UI (i.e. it’s under active development)? Or is there something I need to modify to get the settings page to work as expected?

Thanks to everyone who’s contributing to this awesome project!


I haven’t pulled the latest commits, so maybe something’s broken, I’ll check that soon.
For the time being, you can try some verifications, if you haven’t already done, such as:

  • Clearing browser cache
  • Restart PHP server (sudo /etc/init.d/php5-fpm restart)
  • Reboot raspberry pi

Apart from this setting page, the other webui pages are ok?

I’ve tried clearing and disabling caches, rebooting, and re-starting nginx. I did not try restarting php5-fpm, but a reboot didn’t fix the issue so I don’t expect that will either…

Oh, Jotak - just to be clear, I’m on a Cubox i-4, not a raspberry pi!

I’ve just pulled the latest from git, and don’t have such issue :frowning:

Can you check if you have some javascript errors? (if you can open your browser’s javascript console)

You could also try something, to check if this is due to something corrupted in the database:

  • connect to your device
  • backup and remove the file /var/www/db/player.db (for instance rename it player.db.bak)
  • connect to the webui (you will be asked to run the update script again, just proceed)
  • see if that works

By renaming player.db, you loose all your configuration, and it will be reset by the update script. So if it works, you would have to reconfigure various settings. If it doesn’t work, put your backuped file back and we must continue to investigate :confused:

Backed up and wiped out the player db by running the script - reconfigured the mounts and audio hardware just fine, but still no “system” tab.

One error I’m getting in the developer tools console is a resource error - a 404 not found on the image “http://volumio.local/images/demo/logo-mask-2x.png”, which I get on any of the pages loaded via the “menu” except for when loading the system page. I I don’t think this is related?

I am also getting this error:

GET volumio.local/_player_engine.php … 4096475123 404 (Not Found)

This just sporadically comes up without action, I did not try to play anything after re-setting the player db.

I’m also getting 404 errors on the following URLs:


Times out with 404 after 2 minutes



times out with 404 after 1 minute.

Getting errors like this in nginx’s error log.

2014/10/24 01:41:14 [error] 4076#0: *1215 open() "/etc/nginx/html/50x.html" failed (2: No such file or directory), client:, server: , request: "GET /db/?cmd=playlist HTTP/1.1", upstream: "http://localhost//?cmd=playlist", host: "volumio.local", referrer: "http://volumio.local/index.php"
2014/10/24 01:42:14 [error] 4076#0: *1200 upstream timed out (110: Connection timed out) while reading response header from upstream, client:, server: , request: "POST /db/?cmd=filepath HTTP/1.1", upstream: "", host: "volumio.local", referrer: "http://volumio.local/index.php"
2014/10/24 01:42:14 [error] 4076#0: *1200 open() "/etc/nginx/html/50x.html" failed (2: No such file or directory), client:, server: , request: "POST /db/?cmd=filepath HTTP/1.1", upstream: "", host: "volumio.local", referrer: "http://volumio.local/index.php"

Reboot doesn’t fix this problem, this is all new since updating the UI to the latest git from 10/23.

Yes that is a bug in the 10/23 revision where DB requests will hang if the Spotify daemon is not running. I’ve written a fix and put in a pull request!

Thanks ning-yu - the patch you did fixed the problem of loading content into the “Browse” tab. Great!

However, I am still stuck with the original problem - since updating using the Volumio-WebUI git, my “System” configuration page is completely blank.

If anyone has any ideas how to fix this one, please let me know!

Wanted to bump this thread - Jotak or anyone else on the Volumio dev team: what should I be looking at to diagnose the blank “system” page?

I’ve updated the Web UI via git pull several times now in the last few weeks, as I’ve seen updates to the project. Everything else is working great - all of the other pages work fine, and all playback functionality is working as expected.

I’ve tried looking at the PHP FPM logs, the nginx logs, and the php error logs, and I don’t see anything other than normal access to the “settings.php” page. I don’t see any javascript errors in my browser or anything like that.

My best guess at this time is that there’s something that needs to be done, or installed, to the “Stock” 1.4 image for Cubox that all of the devs have done as part of their development process, that wouldn’t be part of the code getting pulled from Git. It’s a guess, but as I’m not a PHP programmer I can’t really understand what’s going on in the script or why it’s not returning any results…


As always, thanks to the folks that make this awesome project possible!

wait… 1.5 will released soon (~1,5 weeks)

if you cant wait you can look through the threads for the library tab, the update script etc.

I fear that looking at other threads won’t help, since this issue seems different than the other I saw.
So you can wait for 1.5 and hope that a fresh install will wipe this bug out…

But if you prefer to roll up sleeves and, even if you don’t know PHP, we can try one things or two to debug it, I’ll help you with this

Basically, PHP is very funny to debug: pick up a file, write echo "1<br/>"; , echo "2<br/>"; , echo "3<br/>"; etc. in various places, followed by “exit;”, and see what happens. (When I say it’s funny, i’m a bit ironic).

Drop me a message if you’re not afraid to try this

PM sent!

The settings page doesn’t work unless you install some other binaries. But let me tell you, 1.5 is on the way… :wink:

Really looking forward to 1.5.

Re: other binaries, do you mean the “spopd” and its dependencies? I already installed those, it seemed they were relevant looking through the settings.php page. But maybe I’ve done something wrong. Anyway, I’ll try a bit of troubleshooting with Jotak (thanks Jotak!) and we’ll see if I can get anywhere prior to 1.5!

Could you become a little bit more specific on what binaries have to be installed to see the setting page?

I am running a Hummingboard-i1 and the Cubox-i Image is not working, though I built Volumio with the Image from Igor Pecovnik (typingoutloud.org/raspberry-pi-i … io-pibang/ .
I got Everything to but not the “System” Page…

Thanks in advance.


I have the same problem. Anybody can tell me additional packages what I need?
I’m running the Igor’s Debian image on Cubietruck and I do not want to reflash my device for Volumio image.
Thanks in advance.

Can’t PM to any user so nothing to do ither to UP this thread.

I think this has something to do with the spotify integration - the new Volumio UI is looking for “spopd.” However, I’ve installed this by hand with some effort, and it still doesn’t work. I think there’s more, but I don’t know what it is!

So my only recourse at this point is to wait for 1.5 to be released for Cubox-i!

Hmm, I’m not sure what new binaries are included in 1.5, but did you also install the spop dependencies?

  • libspotify
  • Glib
  • JSON-GLib
  • libao