[Solved] Lost 2 SD Cards in 10 Days


i read a lot about issues with corrupted sd cards everywhere when it comes to the raspberry.
My Setup:

raspberry + hifiberry
wifi dongle from edimax
external hard drive with seperate power supply, that is directly connected to the raspberry and holds the music
cheap power supply ( now replaced by samsung power supply for mobilde device with 2A and 5V)
cheap sd card (now replaced by kingston 4gb class 4)

my first setup lasted for 4 days before the raspberry stopped and when i tried to boot it i got a lot of i/o error on the sd card.
i read a lot about this issues and therefore bought the better power supply and a new sd card.
i also changed the habbit of plugging the device out when it does not react.

then i set everything up again.
now 6 days later, system does not react anymore. after reboot reaspberry tells me that it cannot mount root partition.
i tried to repair the sd card with fsck on my ubuntu machine. did not help. then i formatted the sd card and placed the image again on it (with sudo dd).

now raspberry says it is only in read only mode…

i have no idea what i am doing wrong. i got the feeling that i have to buy a new sd card every week… i am so clueless…

i would really appreciate help from the forum, maybe some tipps about what i am doing wrong or if there is anything that i could do to fix the cards or check what is wrong with them.

thank you so much for your help.

I eliminited this problem by moving the root partition to an usb disk. Setup is 100% stable now.

Check this guide
samhobbs.co.uk/2013/10/speed … lash-drive

Are you using windows/mac/or linux to flash your SD Card?

Which programm do you use to flash it?

Can you use your SD Card normaly after you got the Errors in Volumio? (after reformating it)

Im using linux to flash the sd card.

I did it with k-Partition-Manager from KDE.
The SD card is actually normally identified by the laptop.

After mounting i get following errors in dmesg:

[69812.043133] EXT4-fs (sdb3): mounting ext3 file system using the ext4 subsystem
[69818.102511] EXT4-fs warning (device sdb3): ext4_clear_journal_err:4606: Filesystem error recorded from previous mount: IO failure
[69818.102525] EXT4-fs warning (device sdb3): ext4_clear_journal_err:4607: Marking fs in need of filesystem check.
[69819.148123] EXT4-fs (sdb3): warning: mounting fs with errors, running e2fsck is recommended
[69819.270954] EXT4-fs (sdb3): recovery complete
[69819.397901] EXT4-fs (sdb3): mounted filesystem with ordered data mode. Opts: (null)

Would it be better to format the card again with the windows tools that are provided directly from the manufacturers like sd formatter?
As i have a usb hard drive directly connected to the raspberry pi, i believe putting the root partition on this one should also be easily possible when following the posted guide.
So i think i will go like this:
SD Card holding the boot partition.
Hardrive holding the root partition and the music partition.

Still i would really be interested if i did something wrong or if i still have an issue in my setup.


Davy78, thank you again for your comment. This was hopefully the solution. I have now placed the root partition to the external Hard drive that has its own power supply and is directly connected to the raspberry.

The instruction provided was really helpful.

I will monitor the whole things now for some days, but im very confident, that this wil be the final solution.
I even got the feeling that volumio is now a lot faster then before.

Thanks again.