[SOLVED] Last upgrade problem

After downloading and installing the latest update (26/7), Volumio has not restarted. I had this problem with two different players. (RPI2 and RPI3).
Has anyone else had problems?

I am experiencing the same issue. I haven’t upgraded in a long time. Tried on a Rpi 1 A+ and a Rpi 2 B.

Been waiting for about 10 minutes now, but it still will not boot. Looks like it is stuck at moving root and mounting overlay.

Usually goes easy. Not sure what the issue is now.

Same here. Upgrade bricked Volumio on RaspPi 1B.

I’m trying a fresh install now.

Fresh Install also failed with v2.598 on RPi 1B.

Where can I download previous versions to get going again?



I found v2.587 here:

updates.volumio.org/pi/volumio/2 … pi.img.zip

I’ll try that until there is a new fixed version

I had the same problem.
Found this page:

I’ve reverted to v2.587 without issue.

As there are now reports of RPi 1/2/3 all being affected by the current update I would hold off updating any Raspberry Pi until a fixed update arrives.


First post here.
Updated 2 identical players over the weekend, one uses ethernet, the other wi-fi to play from a NAS share, both upgrades went ok. No issues.
Pi’s are 3b each with IQaudIO Dac Pro.


Last update does not okay on Raspberry PI4 as well. It was made to make volumio compatible with RPI4 but there are several errors in the bootlog and volumio starts in emergency mode only.

That was stupid! I bricked my Raspberry Pi A Volumio Card and ordered a new raspberry pi 3, because I thought my old raspberry wasn’t supported anymore. Well, at least everything will run smoother for me once this is fixed. Until then nothing will run at all.
Waiting for an update that doesn’t brick things.

We located a build issue with the newer images for the older PI versions.
Some of us are still on holidays so please give us a week or so to sort this out.

Hi there.

Just being curious as I had problems updating from the latest image:
What happens when you open a login shell (via network or directly) on the Raspberry and run ‘apt-get update’, then ‘apt-get upgrade’?
I saw an error message pointing to run apt manually, which then became interactive to ask a question.

I believe this interactive mode in apt breaks anything integrated into volumio.


See also rpi-with-official-touchscreen-cannot-operate-volumio-t12712.html

Same problem here. Update via menue went wrong. Tried three times the upgrade without success and reloaded the old version image without problem. Waste of time as I had to configure everything from scratch…
Running a Raspberry PI Zero W with USB DAC.
Best regards,

I can’t open a login shell. No route to host. Thing is off the network.
An Unrealease would be fine, so that this doesn’t happen to users who didn’t update yet.

Can you temporarily put a message in the download page to warn not to do so for the older Pi’s (and perhaps put a direct link to the older version there to help people recover)?

I know it won’t help for people who brick their older Pi’s via an update from the web-UI, but it could help them recover it (as I had to do last night).

Today’s version (2.599) should have fixed the issue. Please let us know if that’s the case

2.599 seems ok on an RPI2.

Anyone with successful upgrade on Pi zero, Pi zero W?


was able to update to 2.599 on a raspi zero w successfully, it worked so far. but then i unistalled the spotify plugin, reinstalled it and then rebooted the raspi and what should i say: same behaviour as with the update to 2.598. the raspi didn‘t boot any more, i‘m required to reinstall…

Nevertheless: thx to the team for this great peace of software.


Aye. I was able to boot 2.599 and go through the setup through the WiFi hotspot, I couldn’t with the previous release. But as soon as I rebooted to activate my JustBoom Digiboard, the PiZero was unresponsive again.

It’s looking like RPi’s based on the BCM2835 (ARMv6) are still having an issue with v2.599.

Anyone with this SOC have success ?