[Solved] IQAudio Pi-Dac

Hi… I was very excited to receive the IQAudio Pi-Dac in todays mail. Unfortunately, the Raspberry Pi Volumio1.2beta distribution does not support the Dac without modifications. There are also features in MPD that don’t work just yet. The necessary audio drivers are not in the kernel. After several hours of working through updating the kernel and firmware I am now listening to high quality audio from the Raspberry Pi with the IQAudio Pi-Dac attached. I have not yet enabled hardware volume control, but that will be a future task. The IQAudio Pi-Dac uses the I2s interface for flawless audio. Possibly as the Volumio distributions mature this Dac will be supported directly. I surely recommend the audio quality and easy hardware installation. This Dac provides an alternative to the HiFiBerry, also a wonderful addition to the Raspberry Pi and it supports 24-bit / 192kHz Flac files. There is much more to be done. This is just a first start. I hope this Dac will be supported in future releases of Volumio.

The MPD Configuration under Audio Output does show ‘sndrpiqaudioda’ as the output option.

/etc/modules was edited by hand:

In MPD System settings do not Activate I2S driver as it will overwrite the /etc/modules file with the HiFiBerry values.

Best wishes!

Tracer5, glad you got the board and are enjoying it. I am working with Michelangelo and other to achieve better integration and hope to have more information in the near future. I must thank everyone involved and Michelangelo has been an inspiration.

All the necessary linux drivers are now in github https://github.com/raspberrypi/linux/tree/rpi-3.14.y

Very best regards,


twitter: @IQ_Audio

Hi tracer5,

I am trying to get this going also. Edited /etc/modules as above and rebooted but aplay -l shows no devices as does Volumio. Checked modules again and my edit is still there. Was there anything else that you did?


BTW I removed anything that was already in /etc/modules and replaced with what you had. I assume that was right rather than apend?

Hi ChrisMmm… Yes there is much more to do. The distribution of Volumio 1.2beta does not currently have the IQAudio Pi-Dac drivers in the Linux kernel. It is necessary to update the kernel and the firmware. If you do a :

uname -a

you will find your current version of the Volumio kernel. After updating mine I am at :

3.10.36+ #664 PREEMPT

Mine now has the necessary drivers for limited success. It is very late here in the evening. I will post a step by step later for you, but in just a few days or longer I understand IQAudio will update us all with a proper integration for Volumio. My process is quite crude, but works.

Best wishes - tracer5

Here is a step by step: (Do beware… for IQAudio Pi-Dac testing only)

To update packages:

sudo apt-get update && sudo apt-get upgrade

To update kernel:

sudo apt-get update && sudo apt-get -y dist-upgrade

Use the Hexxeh script to install the rpi-update tool:

sudo apt-get install rpi-update sudo curl -L --output /usr/bin/rpi-update https://raw.github.com/Hexxeh/rpi-update/master/rpi-update && sudo chmod +x /usr/bin/rpi-update

To update the firmware:

sudo rpi-update

you’ll need to reboot to load the new firmware.

Awesome, thanks.

Actually I tried a lot of what you suggest on a Raspbian image but not all. I will try the last few things there first. If I fail, back to Volumio!

Update: Yes I have music! Used the Volumio SD and followed your updates, all good. Many thanks.

Not sure why the straight Raspbian SD didn’t work, after all Volumio is Raspbian based.

Hi Chris Mmm…

Glad to hear that you have music from your IQAudio Pi-Dac. This interim solution is certainly not optimized, but should be very stable.

Any comments on Pi-Dac sound quality?

Best wishes - Tracer5

Hi, I am setting this up for a friend, my current digital source is a Rpi with ES9023 DAC via I2S. after a brief listen I would be hard put to tell the difference between the two. Very happy with both.

I have got my IQaudIO Pi-DAC running by following the same steps. Thanks Gordon for his support!
The setup sounds awesome, I am really happy with it for the amount invested! I have heard some much more expensive devices that didn’t sound half as good.

Guys, I finished the 1.3 version which will feature the IQ Audio DAC support… And, it is just brilliant! It sounds really really good!
You’ll find it soon on download page! Great work Gordon!

Awesome, can’t wait to try it - Is the MPD issue with volume resolved too Michelangelo?


You can try it:


You have however to edit the mpd.conf manually…

And volume, unfortunately has not been fixed…

Let me know your feedbacks, prior to official release…

Hi Michelangelo,
The VolumioBeta1.3BISPI image file has a small problem with how it writes to the /etc/modules file for the IQAudio Pi-Dac. By selecting Iqaudio the following entries are in /etc/modules:

snd_soc_bcm2708 bcm2708_dmaengine snd_soc_pcm5102a snd_soc_iqaudio-dac

I believe /etc/modules should be:

Best wishes - tracer5

Thanks Tracer!
You see… Lots of things to do and I make those silly errors… What you think about the rest? Anything I should fix ?
This release features mpd 18.9 … Let me know !

MPD 0.18.10 is out now. Too slow! :wink:

Firstly - ALAC is working Michelangelo :slight_smile: Thanks! Most of my music library is ALAC.

Can confirm that 1.3beta places the following in /etc/modules for IQaudio

and it should be:


Also, if you could rename the board under Settings/Activate I2S driver

IQaudIO.com Pi-DAC”

that would be great.

More importantly, I think an initial volume of 0 (mute) or 20% rather than 100% - may be a better fail safe :slight_smile:

If we want hardware volume control then the following will work but with the known MPD volume ratio issue.
change /etc/mpd.conf to have “Playback Digita” rather than “PCM”:

audio_output {

             type           "alsa"
             name           "Output"
             device         "hw:0,0"
             mixer_control  "Playback Digital"
             mixer_device   "hw:0"
             mixer_index    "0"
             dsd_usb        "yes"


This gives control from approx 50% on the dial but with little output before reaching 50%

A couple of other things I noticed…

  • Once as I2S selection is made you cannot easily tell which has been selected. (possible to change button colour or something?
  • Maybe put the DAC selection in alphabetical order?
  • ALAC support :slight_smile: You’ve made me a happy man

Best regards,


Hi… another issue is shairport.

sudo /etc/init.d/shairport start sudo: /etc/init.d/shairport: command not found
this does start shairport and it works very well:

/usr/local/bin/shairport -d -a "Volumio" Listening for connections. 18557 pi@volumio:/etc/init.d$ Established under name '04255CB411F0@Volumio'
Any ideas?

The Pi-DAC is back in stock - purchase direct on tindie.com


Any update on cases?